Linux-lts y linux-zen no arrancan con Nvidia

Hola

Tengo instalado Plasma y agregue los nucleos lts y zen con sus correspondientes headers o cabezeras, luego al poder elegirlos en grub no arrancan, solamente inicia session sin problemas el kernel actual.

Como no tengo experiencia con las gráficas Nvidia, faltará instalar los controladores de Nvidia para lts y zen ?

Gracias de antemano.

Probablemente necesite cambiar a nvidia-dkms

Original:
You probably need to switch to nvidia-dkms

1 Like

Hello @dalto!

Yes, you are right since dkms-nvidia works in groups for the other kernels or when there are more than one.

$ sudo pacman -S nvidia-dkms
[sudo] password for judd: 
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (1) nvidia-dkms-440.82-1

Tamaño total de la descarga:    13,10 MiB
Tamaño total de la instalación:  32,87 MiB

:: ¿Continuar con la instalación? [S/n] 
:: Obteniendo los paquetes...
 nvidia-dkms-440.82-1-x86_64                                                                                                            13,1 MiB   912 KiB/s 00:15 [-----------------------------------------------------------------------------------------------------] 100%
(1/1) comprobando las claves del depósito                                                                                                                          [-----------------------------------------------------------------------------------------------------] 100%
(1/1) verificando la integridad de los paquetes                                                                                                                    [-----------------------------------------------------------------------------------------------------] 100%
(1/1) cargando los archivos de los paquetes                                                                                                                        [-----------------------------------------------------------------------------------------------------] 100%
(1/1) comprobando conflictos entre archivos                                                                                                                        [-----------------------------------------------------------------------------------------------------] 100%
:: Procesando los cambios de los paquetes...
(1/1) instalando nvidia-dkms                                                                                                                                       [-----------------------------------------------------------------------------------------------------] 100%
:: Ejecutando los «hooks» de posinstalación...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Install DKMS modules
==> dkms install nvidia/440.82 -k 5.6.14-zen1-1-zen
==> dkms install nvidia/440.82 -k 5.6.14-arch1-1

Good news! Module version 440.82 for nvidia.ko.xz
exactly matches what is already found in kernel 5.6.14-arch1-1.
DKMS will not replace this module.
You may override by specifying --force.

Good news! Module version 440.82 for nvidia-modeset.ko.xz
exactly matches what is already found in kernel 5.6.14-arch1-1.
DKMS will not replace this module.
You may override by specifying --force.


Good news! Module version 440.82 for nvidia-drm.ko.xz
exactly matches what is already found in kernel 5.6.14-arch1-1.
DKMS will not replace this module.
You may override by specifying --force.
==> dkms install nvidia/440.82 -k 5.4.42-1-lts

$ pacman -Qs nvidia

local/egl-wayland 1.1.5-1
    EGLStream-based Wayland external platform
local/lib32-nvidia-utils 440.82-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 440.82-1
    NVIDIA NV-CONTROL X extension
local/nvidia 440.82-17
    NVIDIA drivers for linux
local/nvidia-installer-db 2.2-1
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3-2
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 440.82-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 440.82-1
    NVIDIA drivers utilities

Thanks @dalto and I hope this works for another user.

1 Like