Linux-lts booting into emergency shell

I installed linux-lts plus headers via akm, lts boots into emergency shell- what did i do wrong and how do i fix it?

pacman -Q linux linux-lts
linux 5.10.16.arch1-1
linux-lts 5.10.17-1

We need some logs (e.g. journal) to see the actual problem. Please take a look at: https://endeavouros.com/docs/forum/how-to-include-systemlogs-in-your-post/

There is no log for the boot attempt in question, and the keyboard is dead in the emergency shell.
All i have is a friggin photo:

Does linux boot?

That looks like it might be an initramfs problem.

Can we see the contents of /etc/mkinitcpio.conf?

Yes, it does.

It is odd having linux and linux-lts in the the same kernel branch.

mkinitcpio.conf:

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=()

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=()

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base udev autodetect keyboard keymap consolefont modconf block lvm2 filesystems fsck"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect keyboard keymap consolefont modconf block lvm2 filesystems fsck"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev autodetect keyboard keymap consolefont modconf block lvm2 filesystems fsck"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev autodetect keyboard keymap consolefont modconf block lvm2 filesystems fsck"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev autodetect keyboard keymap consolefont modconf block lvm2 filesystems fsck"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect keyboard keymap consolefont modconf block lvm2 filesystems fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"
#COMPRESSION="zstd"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

What is the output of:

sudo mkinitcpio -p linux-lts  
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 5.10.17-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating xz-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 5.10.17-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating xz-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful

Does it still fail to boot the lts kernel?

Still fails, yes.

I just found i have exactly the same behaviour on arch, only difference is the manual kernel installation and nvidia non-dkms.
Let’s close this thread, i guess/hope it is an issue which will disappear as soon as the arch stable linux package is on 5.11

Should have tried that before, sorry.

1 Like

Closed per request. Let us know if we need to re-open it in the future.