Linux Boot option disappears from my system boot manager

Cross your fingers and reboot!

2 Likes

@pebcak My Hero!!! :smiling_face_with_three_hearts: :kissing_heart: :crazy_face: :1st_place_medal: :trophy:

So should this happen again can I simply run the “efibootmgr” commands ?
p.s. on another topic FYI
I like Plasma, I had an issue with my vector graphics package “Inkscape” crashing with Wayland, turns out the problem was that I had to unplug my tablet :face_with_spiral_eyes: Inkscape is aware of the problem and next release will address that.

Can I make a transcript of this thread?? or do I just copy/paste everything?

again , my eternal gratitude

1 Like

If my reading of the fallback boot path for removable devices is correct, this should not happen again. Or at least if you loose one EFI boot entry, you should still be able to use the fallback.

You could bookmark this thread, should you need to refer to it in the future.

Screenshot from 2024-06-08 21-30-27

Also, don’t hesitate to create a new thread if you have doubts, questions or else.

And please consider checking the solution box under the relevant post giving the solution. The forum software will mark the thread as solved and if there are other users with similar issue, hopefully they will find the solution more easily.

1 Like

@pebcak Hiya, just thought I’d let you know, last night I powered down and removed my drive, This evening I plugged in the drive and tried to boot up and again The system boot manager did not see my drive, so I went through the steps we did to correct the problem and it worked.
I think I might have to learn how to write a script that I can run, as I’m getting the sense this is going to happen again.
any ideas what my next move should be would be appreciated.
Thanks for your attention

I am at a loss as to explain what might be the cause that you loose your EFI boot entries and thereby the possibility to boot your system installed on an external disk.

If I were to speculate:

systemd-boot doesn’t support booting from an external disk. However, since it installs the bootloader binary to the fallback path \EFI\BOOT\BOOTX64.EFI, even though it doesn’t create an EFI boot entry for it, I am not sure that this may be the case.

Your machine’s UEFI implementation will effectively remove all the EFI boot entries for disks which are not connected to the system.

This is of course me “thinking freely”. There might be other causes for this behavior known to more advanced users.

If you are up for testing to discard the propositions made above, you could install another Linux system using Grub on your external disk, for example Linux Mint (or anything else of your choice).

Boot it up and check with efibootmgr to see if it has created an EFI boot entry pointing to the bootloader installed in the fallback path. If not, use grub-install (or perhaps grub2-install) with --removable option.

Use the system for a while. Shut it down and disconnect the disk. Start your system and go into UEFI settings and check if the EFI boot entries are there.Connect the disk and see if it is recognized by the UEFI and it is bootable.

@pebcak I tell ya it must be “Gremlins” :smiling_imp:

After fixing the drive with the steps we covered originally.
To Fix Problem …
[liveuser@eos-2024.04.20 ~]$ sudo mount /dev/sdc1 /mnt
[liveuser@eos-2024.04.20 ~]$ sudo pacman -S tree
[liveuser@eos-2024.04.20 ~]$ tree /mount
then…
sudo efibootmgr --create --disk /dev/sdc --part 1 --loader ‘\EFI\systemd\systemd-bootx64.efi’ --label “Linux Boot Manager” --unicode

sudo efibootmgr --create --disk /dev/sdc --part 1 --loader ‘\EFI\BOOT\BOOTX64.EFI’ --label “Boot Fallback” --unicode

The second time, yesterday, I did a System Update thru the Welcome Assistant, which I didn’t do the first time (this being the only difference) when asked to restart, I did, holding my F11 key when restart initialized and no problem everything went smooth. Played around with Blender a bit then powered down and disconnected the drive once again.

This morning I tried again reconnecting my drive and starting up “F11”
and there it was! the Linux Boot and Fallback options, Yay!
Now will this happen again ?? only the :smiling_imp: knows :laughing:

I’ve marked this snippet as “the Solution” but please read through the entire thread to understand what the steps mean.

I’ll keep you informed of any developments (if you’d like)

1 Like

Sure, please do so!

Quick test, using Blockquote for snippets of the conversation, I tried using BBCode [quote=pebcak] … [/quote] but this did not work

Okay, got it :grinning:

@pebcak
Well, I’m back at square one, it’s gone and done it again only this time when I try our steps to fix it, I get this new warning
[liveuser@eos-2024.04.20 ~]$ sudo mount /dev/sdc1 /mnt
mount: /mnt: WARNING: source write-protected, mounted read-only
[liveuser@eos-2024.04.20 ~]$ tree /mount
/mount [errror opening dir]

0 directories, 0 files

:cry:

EOS re-installed and ready for round 2, wish me luck :wink: