🎅🏾 Linux 6.1 is here!



Already installed via testing branch. Happy because of the improved btrfs performance.


Lot problems. Mouse wheel on Logitech Performance MX, like stupid fast, and can’t run Nvidia 470 drivers.

I mouse wheel from my MX Anywhere was a little messy to. I turned on Scroll Wheel Resolution on Solaar an everything re-worked as it should.

If proprietary drivers don’t, that isn’t the fault from the kernel devs.

I have it running on my desktop PC as 6.1.0-zen1-1-zen since yesterday incl. zfs-dkms. No issues detected so far.

Can’t build module for Nvidia 470.

1 Like

Interesting, I updated the packages today, but the kernel hasn’t been updated yet

Have you enabled the testing repo?

Sorry, I didn’t notice that it is currently only available in the testing branch.

Only for info. When you think 6.1 Will be moved in stable repo? Try to guess… Days, weeks or months? Thanks

6.1.1 is already in testing, think before the end of the year it will be in the stable repo.

The Kernel Y.X.0 comes rarely in the stable, normaly they comes with Y.X.1 or Y.X.2 and after the new version (Y.X.3…) come most of the time only a day after release.

So wee speak of 2-3 weeks far a major release and 1-2 day for minor releases.

Thanks :grin:

Today :wink:

1 Like

Released now! All OK so far…

1 Like


I installed the 6.1 kernel. Everything still works as smoothly as before.

Same error. I had to install the nouveau driver to boot the operating system.

nvidia-inst --nouveau

How to install this kernel? I don’t find it with pacman. I can see it is released in the arch core repo.

Just update your system with:

sudo pacman -Syu

You probably already have the package linux installed, and if it is on the older version, it will be updated to “6.1.1.arch1-1” (at the time of writing this post).

If you don’t have it installed:

sudo pacman -Syu linux

When I try to do sudo pacman -Syu linux. I get linux-6.0.12.arch1-1 is up to date – reinstalling.