Linux-5.4.8.arch1 Causes Asus VivoBook w/ Ryzen 3 to Freeze on Boot

I have an Asus VivoBook 15 with a Ryzen 3 processor and Radeon Graphics. I had loaded it up with Endevour about two months ago and for the most part everything was running well. This morning however I ran some updates and now it is hard freezing on boot with just a black screen. Keyboard does not respond to any input. I edited the Grub boot options with “nomodeset” and removed “quite” and now I can see that it might have something to do with Simple Desktop Display Manager as I’m getting the following error messages:

[OK] Started Simple Display Manager
[OK] Created Slice system-systemd/x2dcoredump.slice
[OK] Process Core Dump (Pid 703/UID 0)
[OK] Reached target Bluetooth
[OK] Stopped Simple Display Manager
[OK] Started Simple Display Manager
[OK] Process Core Dump (Pid 718/UID 0)
[OK] Stopped Simple Display Manager
[OK] Started Simple Display Manager
[OK] Process Core Dump (Pid 718/UID 0)
[OK] Stopped Simple Display Manager
[OK] Started Simple Display Manager
[OK] Process Core Dump (Pid 731/UID 0)
[OK] Stopped Simple Display Manager
[OK] Started Simple Display Manager
[OK] Process Core Dump (Pid 742/UID 0)
[OK] Stopped Simple Display Manager
[OK] Started Simple Display Manager
[OK] Process Core Dump (Pid 752/UID 0)

At this point, the system is entirely unresponsive. I have tried booting to lower Init levels (3, 2 and 1) and I still end up with an unresponsive system. I am unable to login at this point because it hard locks. I think I will need to pass some grub parameters to prevent simple display manager from loading so hopefully I can at least login to a terminal but I don’t know what that should be.

Are there any suggestions on how I might be able to fix the issue?

Thanks!

[Ctrl+Alt+F2] shows login? if yes you can stop sddm --> sudo systemctl stop sddm then install another one:


No, the keyboard is unresponsive, I cannot get to a login screen using Ctrl+Alt+F2. I think I will need to pass a grub parameter if possible to prevent SDDM from loading before I will be able to login to a terminal.

hello, do you have sddm installed or do you have another

Yes, I think SDDM is my current display manager. I installed KDE and I think SDDM is the standard display manager for KDM if I recall correctly.

that’s the only thing i found https://www.reddit.com/r/archlinux/comments/8wctai/archlinux_hangs_on_boot_i_assume_its_sddm_and_i/

can you check https://wiki.archlinux.org/index.php/SDDM#Blank_screen_with_cursor,_but_no_greeter_shows ?

df -h of your drive,

just as joe noticed to bootintoo system directly in terminal (tty)

one of them is adding this in grub , e for edit and in the kernel line :slight_smile:

put systemd.unit=multi-user.target right after rw like this:
rw systemd.unit=multi-user.target resume=....

you can log in and that way check df -h ; to check if the disk is not full.

1 Like

I tried using the

systemd.unit=multi-user.target

command. This time it loads me to a login prompt, the curser blinks a couple of times and then freezes before I can login.

Using the link JR29 provided, I followed the instructions and managed to boot from a USB drive and CHROOT into the laptop. I then ran the

systemctl disable sddm

This time it will boot all the way to a terminal login screen but then promptly freeze right after that before I can login. I am guessing that SDDM might have been a symptom but not the problem.

What would be the best log file to look at? I assume syslog but is there anything else I should look at?

Thanks for all the help!

Has been awhile since I installed Endeavour and then KDE-plasma. I seem to recall lightdm being installed (which I deleted after adding/enabling sddm)

1 Like

if you chroot in, you have to do df -h atleast… dont know also the base of your issue…

sddm freez by disk full and other bug

Thanks to all of the suggestions, I ended up chrooting into the system from a USB install stick and downgrading the linux kernel from 5.4.8 to 5.4.6 and now it boots again. I re-titled my original post accordingly as this was not an SDDM issue after all but a Kernel error. It appears that there is something with the Ryzen 3 and Kernel 5.4.8 that causes the problem. Now it is just fingers crossed that there will be an update to the kernel to fix whatever is causing the hang.

This brings up a secondary question however… I think on Ubuntu whenever you updated, it would always keep the previous kernel version installed so you could select it at boot if necessary. Is there a config option available in Arch to keep the previous kernel available in Grub?

@adamis, not only in Ubuntu (e.g. here in siduction this is also very advisable). This is not provided for in arch and therefore also in endeavouros (in manjaro this is possible, afaik, there is also a corresponding administration tool). However, you can install the LTS kernel in parallel as a fallback option.

1 Like

hello what do you have graphics card driver

Try installing lightdm and see if it is working on lightdm.

you can set current kernel to ignore… you have to set in /etc/pacman.conf

https://wiki.archlinux.org/index.php/Pacman#Skip_package_from_being_upgraded

as temporarely messures… but also keep your disk space in sight… can cause some hanging too.
my self have rijzen 5 2600? with vega 8 … only got some gpu distrortion issue if i set vblank in xfwm4 set to automatic , xpresent or off is fine… issue is stil there in the kernel , lts does not have that… but next month is current linux , become lts…if the new kernel come.

In response to JR29: I believe I am using the Radeon open source driver that comes with the kernel. I did not install any proprietary drivers after the initial install.

im using the amdgpu driver

5.4.8 kernel boots fine on my unit with AMD 7 2700X cpu
(and radeon gpu)

Just a follow up to this thread, it appears it is a kernel issue that has been resolved in 5.4.14 according to this thread:

Note… I was going to update my original post to include this information and mark it as resolved but for some reason I don’t have an edit button for my original post so I’m posting as a reply.

1 Like