Links mix up

Whenever I click on a link to the internet, KDE activates a “wine browser,” which of course is non-existent. At the same time some notification appears at the bottom right corner of the display, saying something about kio and some files–which I cannot read because it appears and disappears too fast. Then this wine glass just bounces its merry way about, following the cursor, with no way to stop it.

This happened after I installed STEP Bible of Tyndale House ( through Wine. STEP Bible is supposed to open a localhost in the default browser, in my case Firefox, but has ended up activating “wine browser.” And it’s not only STEP Bible but other links to the internet as well, including links in the Welcome module to Wiki and Forum. Click them and you get the eternally bouncing wine glass stalking the cursor.

What to do? I couldn’t find a topic like this in the forum.

Hello @cain2log
Did you install Wine?

Post this command
pacman -Q wine

Hi @ricklinux
yes,I installed wine via Discovery

pacman -Q wine returns “wine 5.8-1”

What is it you are trying to do? Wine is used to run Windows programs? Did you download STEP for Windows?

Yes, STEP for Windows. This is a free software, which I used to run in Linux Mint Cinnamon with no issues at all.

When launched, STEP (through Wine?) is supposed to open the default browser and connect to localhost:8989. But KDE makes it seek a non-existent wine-browser. I don’t know how and why KDE keeps seeking and trying to unsuccessfully open a wine browser instead of the legitimate browser, Firefox in this case. And this now affects not only the launcher for STEP, but other links as well, as stated in my first post.

P.S. Sorry for the delayed reply. My laptop just keeps unexpectedly shutting down. I don’t know if this is EOS-related. Something else I need to look into.

I’m not sure either i don’t have much experience using Wine. But if you’ve run Wine before you obviously understand how to use it. It’s probably something not right. I just know that it is a compatibility layer to allow running Windows executables. You are running it on KDE so something is not working properly. Off hand I’m not sure what to tell you. I would have to install it and see.

Edit: I’m installing it on v-box for a minute to have a look. It will take me a little time while it downloads and installs.


The issue seems to be related to “kio,” the only letters I could remember from the notice popup that appears and displays some directories/files.

The KDE application launcher says kio is “Browser Identification.” So, I’ll read up on this.


I think i already know what it is but not sure on the fix. Yet!

1 Like

Wine was complete garbage the only time I tried it

It was running excellently on Linux Mint Cinnamon, running several (free) Windows programs I had. At the moment on KDE, it is running another Windows program (theWord, which launches without opening a web browser) with no issue at all. It think the problem most likely has to do with Browser Identification. I just need to learn about it now. Reading on it.

I tried it about 2 years ago on KDE Neon so I could use photoscape and Potplayer, but both programs worked like garbage and wine screwed up my system

Okay i have an idea. The mimeapps.list file may have changed on your system. Could you post the link to this command. I will compare it to mine.

cat ~/.config/mimeapps.list | curl -F ‘f:1=<-’

[agila@ndvros ~]$ cat ~/.config/mimeapps.list | curl -F ‘f:1=<-’
bash: -’: No such file or directory
cat: /home/agila/.config/mimeapps.list: No such file or directory
[agila@ndvros ~]$

Did you copy my command?

Yes, copy-pasted.

Can you check if it has the file? You go in home folder and show hidden files under view. Then open the .config folder and see if mimeapps.list is there? You can open it with a text editor to view it such as kate on kde.

mimeapps.list is really not in the .config folder

So the file is not there?

no; and a generalized search cannot find it anywhere in the system