Limited Connectivity After Updating System

Not computer nerd here. Here’s the issue I have no idea how to fix:
I updated my system and now internet connectivity is stuck at being limited.
First steps of reconnecting, connecting to a different network, rebooting, and booting into fallback and lts still have the same issue.
Pinging always comes back as a failure, and the solutions to a few similar issues didn’t help either.
Tried reading a bit into the wiki, but it’s no The Very Hungry Catterpillar. Pretty lost on how to fix this myself, so I’d appreciate any help I can get.

Hello @SkilletIssue
Are you on Wifi or connected via ethernet? Can you post the following?

inxi -Na

Also, default EnOS config has firewalld set to block incoming pings. I.e. pings go out, but results can’t come back in.

1 Like

I’m connected through wi-fi, and the command came back with this:

Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280

You could try this link to see, if your Wi-Fi 6 AX201 chipset is compatible with linux at all:

My suspicion, it might not even be supported!

1 Like

The chip is supported, and I haven’t had any network problems for a few months until now after switching to Endeavour.

A thorough web-search for these terms might help:

Arch Linux issue Wi-Fi 6 AX201 chip

Did you install the linux-firmware package?

sudo pacman -S linux-firmware

…and reboot could be helpful.

Installing linux-firmware and rebooting Sadly didn’t help, and any similar AX201 problems I could find contained solutions I’ve already tried, which weren’t successful if I had to assume from the persisting problem.

There’s an overview of your Wi-Fi 6 AX201 on linux -

Tpye in:
Vendor: Intel
Device: Wi-Fi 6 AX201

Then click Find beneath the search-fields.

According to that list, it works in most cases.

What is your detailed hard- and software system?
inxi -Fzxxa

(Please see how to post systemlogs here.)

1 Like

Could you also provide

inxi -Faz | eos-sendlog

You could try setting a parameter in



options iwlwifi bt_coex_active=0

EDit: You may need to create this file using a text editor such as nano and then add the module options as above and save the file.

Also, disabling fast boot in UEFI bios might help.

Not sure what would be useful, but here’s what showed up:

  Kernel: 5.19.11-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
    root=UUID=f6513ec3-5bfc-4343-b637-0f98075bdeab rw rootflags=subvol=@
    resume=UUID=c0352002-7fe8-47ce-aa45-c42a554eea56 loglevel=3 nowatchdog
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
    dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HP product: HP Laptop 17-cn0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 883C v: 69.18 serial: <superuser required> UEFI: AMI
    v: F.20 date: 03/03/2022
  ID-1: BAT0 charge: 36.2 Wh (100.0%) condition: 36.2/36.2 Wh (100.0%)
    volts: 12.5 min: 11.3 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: full cycles: 4
  Info: model: 11th Gen Intel Core i3-1125G4 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 built: 2020 process: Intel 10nm
    family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1278 high: 2000 min/max: 400/3700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1040 2: 1194 3: 825
    4: 725 5: 2000 6: 1134 7: 2000 8: 1307 bogomips: 31960
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Tiger Lake-LP GT2 [UHD Graphics G4] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 0000:00:02.0
    chip-ID: 8086:9a78 class-ID: 0300
  Device-2: Chicony HP TrueVision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:3 chip-ID: 04f2:b710 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0953 built: 2020 res: 1920x1080
    hz: 60 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
    diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.19.11-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
  Local Storage: total: 476.94 GiB used: 294.81 GiB (61.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: HPS1
    temp: 38.9 C scheme: GPT
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 294.81 GiB
    (63.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 1.2 MiB
    (0.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 294.81
    GiB (63.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 294.81
    GiB (63.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 41.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 245 Uptime: 0m wakeups: 55 Memory: 7.44 GiB used: 1.31 GiB
  (17.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 alt: 11 Packages: pm: dpkg pkgs: 0 pm: pacman
  pkgs: 1292 libs: 385 tools: yay Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.21

Also after 19 seconds, reports that it could not resolve host when doing eos-sendlog

Just came across this:

So there should be an update for your UEFI bios available at HP Customer Support for your machine. It could help to install it.

Looks like your UEFI Bios is fairly recent but i would check if there are any updates. I can’t check because i don’t know the exact model of your HP product but there may be additional updates.

Updated the bios and still can’t connect to the internet properly.
A friend suggested to boot from a drive, and I was able to connect to the internet perfectly fine from there, but not sure what to do with that information.

Did you set bluetooth coexist as i suggested above?

Yes, although it didn’t seem to have any effect

Have you checked your router settings. Most people do not have newer routers that support the AX WiFi 6 standard so it will be connecting using the WiFi 5 standards. You may want to check your settings. Although they are backwards compatible you may want to experiment with different settings such as different channel. If you are dual booting with Windows make sure fast startup feature on Windows is disabled.