Lightdm not working with resolution

Hello guys, newbie here.

Finally I try i3, but aperretly I failed.

When i have default value in Display Manager lightdm and reboot system, I always have 1024*768. But when I choose gdm, reboot, everything work correctly.
Even though I try export config monitor.sh from arandr(in gdm) and put in config i3 then reboot and try lightdm again, it still doesn’t work.

Any idea’s?

xandr here:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

monitor.sh

#!/bin/sh
xrandr --output DP-0 --off --output DP-1 --off --output HDMI-0 --off --output DP-2 --off --output DP-3 --off --output DP-4 --primary --mode 3440x1440 --rate 100 --pos 0x0 --rotate normal --output DP-5 --off --output USB-C-0 --off
1 Like

Welcome Aboard!

the monitor.sh file does not go in config i3.

How does lightdm fail?

Follow the steps on the Endeavouros wiki for setting this up: https://discovery.endeavouros.com/window-tiling-managers/i3-wm/2021/03/

Make sure to set the display as primary.

Reboot and see what happens. If it fails again try the LTS kernel.

monitor.sh is just my config from Arandr, and I put it in ~/.config/i3/config just like in the wiki:

exec --no-startup-id ~/.screenlayout/monitor.sh

lightdm don’t fail at all, I just have only 1024 x 768 resolution, and I can’t change it. In Arandr appears only this resolution.

EDIT: Well it’s pretty weird, after several restart and plug in / out cabel from GPU lightdm start normal with corret resolution 3440x1440, and in Arandr I saw primary display, but after restart again, it does’t work again. :frowning:

gdm work fine.

lightdm needs to have a display setup in configuration…

1 Like

Thank you, it looks like i3 doesn’t like me :slight_smile:

I tried everything what’s in the video, step by step, but with no result. Maybe it’s something when OS boot? Because when I try restart lightdm it’s show up with correct resolution 3440x1440.

sudo systemctl restart lightdm

Can you post inxi -Fxz ?

Yea, no problem

https://pastebin.com/HYqisa9D

Curious, do you have the nvidia driver installed? cuz loaded: modesetting,vesa unloaded: fbdev

Can you pacman -S glxinfo and then post inxi -Gx ?

Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2070] 
  vendor: Micro-Star MSI driver: nvidia v: 470.57.02 
  bus-ID: 26:00.0 
  Device-2: Microdia Dual Mode Camera (8006 VGA) 
  type: USB driver: hid-generic,usbhid bus-ID: 5-2:3 
  Display: x11 server: X.Org 1.20.13 driver: 
  loaded: modesetting,vesa unloaded: fbdev 
  resolution: 1024x768~76Hz 
  OpenGL: renderer: llvmpipe (LLVM 12.0.1 256 bits) 
  v: 4.5 Mesa 21.1.6 direct render: Yes

Can you install the nvidia driver with pacman -S nvidia-installer-dkms ?
after installation run nvidia-xconfig
Wait, on second thought, the driver is present nvidia v: 470.57.02 but it’s not loaded

It said that “reinstall nvidia-installer-dkms”

After that I try run nvidia-xconfig but with an error:

WARNING: Unable to locate/open X configuration file.


WARNING: Unable to parse X.Org version string.


ERROR: Unable to write to directory '/etc/X11'.

did you use sudo?

Also can you try to boot with these kernel parameters? nvidia nvidia-drm.modeset=1 nvidia_modeset nvidia_uvm nvidia_drm

In grub press e then insert the values after quiet on the string of vmlinuz

Yes I try that.

With sudo:

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

without:

Using X configuration file: "/etc/X11/xorg.conf".

WARNING: Unable to parse X.Org version string.


ERROR: Unable to write to directory '/etc/X11'.

Try to reboot now and see if it works!

EDIT : Post inxi -Gx after reboot

Hmm, interesting, after several reboots it looks like it work, I have still correct resolution, reinstall dmks and use nvidia-xconfig seems work?

here it is:

Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Micro-Star MSI driver: nvidia v: 470.57.02 bus-ID: 26:00.0 
           Device-2: Microdia Dual Mode Camera (8006 VGA) type: USB driver: hid-generic,usbhid bus-ID: 5-2:3 
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting failed: nvidia resolution: 3440x1440~100Hz 
           OpenGL: renderer: llvmpipe (LLVM 12.0.1 256 bits) v: 4.5 Mesa 21.1.6 direct render: Yes

Well, the monitor is working but loaded: modesetting failed: nvidia resolution: 3440x1440~100Hz nvidia driver failed to load, can you post your /etc/X11/xorg.conf ?

Also, the vesa module was causing the issue with the monitor.
@joekamprad is right, it’s better to create/edit /etc/X11/xorg.conf.d/20-nvidia.conf for configuration and ditch xorg.conf

still not loading the driver…

Also i would not recommend to use nvidia-xconfig on archbased… you can usenit to create a X11 configfile and then use the needed parts of it to create p.e. display config e.tr.c. as the file /etc/X11/xorg.conf is not needed and it is recommended to only lose files under /etc/X11/xorg.conf.d/ for specific settings you want to change from defaults…

i would like to get one from you and give one to you:

Provide boot log:
journalctl -b -0 | eos-sendlog

and try to set lightdm to wait for gpu/X to be fully initialized:
lightdm has an issue where it sometimes happens that it starts too fast – before X is ready, or the GPU driver is fully loaded. One solution is to set logind-check-graphical=true inside lightdm.conf

1 Like

Here boot log: https://clbin.com/TF50m
Here it is config file xorg.conf:


  GNU nano 5.8                                                                                     /etc/X11/xorg.conf                                                                                               
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 470.57.02


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

logind-check-graphical=true it’s already set to true and uncomment