Libreoffice utilities not launching correctly

Does anyone else have any issues with Libreoffice fresh at the moment? I can launch any of it’s applications via the Libreoffice Start Centre, but if I try to launch an application (e.g. Writer) directly then an icon will appear in the task bar, but the application does not actually launch. The same thing happens when trying to open a file associated with a Libreoffice application or when trying to launch the application directly from the terminal, e.g.

libreoffice --writer

You haven’t mentioned which Desktop Environment you are using or whether you are using Wayland or Xorg.

If you are running Plasma on Wayland, it may be a bug that will be fixed in 7.4.2 which will be released this week.

KDE on Xorg.

Just installed this and having zero issues on KDE with Xorg, what output does the terminal give you when you try to launch it this way? I may not have a solution but a bit more info never hurts espcially when it comes down to trying to figure out the issue.

Just tried removing libreoffice (pacman -Rns libreoffice-fresh), purging ~/.config/libreoffice/ & reinstalling it (pacman -S libreoffice-fresh). Still no dice. libreoffice --writer produces no output in the terminal. Interestingly, each application will launch correctly the first time after reinstallation, but then the problem returns.

Hmm… If I right click on the application in the task bar after it attempts to launch, then select “More” > “Maximise”, the application appears again. Weird.

Hmm, have you set any window rules for it by any chance? Or maybe setting a window rule will help solve this (at least temporarily)

Just looked and I’ve not set any window rules.

This is a LibreOffice bug. It’s already fixed, but it will need to wait for next LO release.
Note that this bug only manifests if you maximize the app window before exiting the app.


Thank you.

Is that just in KDE plasma though?

Edit: don’t seem to have that problem on Gnome… I use libre office-still. Ok saw topic was about fresh, nevermind.

Works here on Xfce.

$ pacman -Q libreoffice-fresh
libreoffice-fresh 7.4.1-4

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.