Lenovo ideapad l340 - glitching and cs:go not runing sometimes

Hi,
Recently I installed EOS and first thing I had noticed is that when laptop comes back from the sleep mode (when i open it) some letters are missing and almost everything is black (similar thing sometimes happens in cs:go). In addition when I tried to play cs:go it sometimes just dont run (black screen appears for few seconds and it closes). I didnt noticed any pattern it just works and the other time doesnt. I also noticed some laggy behaviour while typing in Opera. I assume it all have something to do with drivers but im not sure really. I only installed the nvidia one via endeavour-installer i found on page. I will send any log you need - just tell me how to get it. Thanks in advance!

You could post the hardware link from this command.

inxi -Faz | eos-sendlog

https://clbin.com/1wAfE
Here you go

What does this show?

systemctl status nvidia-suspend.service

○ nvidia-suspend.service - NVIDIA system suspend actions
Loaded: loaded (/usr/lib/systemd/system/nvidia-suspend.service; disabled; vendor preset: disabled)
Active: inactive (dead)

This may be helpful to try by adding this option in the kernel module and enable the nvidia-suspend.service

https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#Screen_corruption_after_resuming_from_suspend

Im not sure how can I do it really… Where can i find kernel module and where i should put this option exactly?

There are a couple of different ways it can be done. If you want to test it as I’m not even sure this will give you the result you are looking for.

sudo nano /etc/default/grub

add this to the grub command line after “quiet”

NVreg_PreserveVideoMemoryAllocations=1

To save the file ctrl + o then enter
To exit nano ctrl + x

Or you can just use ctrl + x and answer yes

Then update grub with this command

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then enable the nvidia-suspend.service

systemctl enable --now nvidia-suspend.service

Okay I think it really helped - did both things at once tho so dont know if both were neccssary. Thanks a lot!
Any ideas what to do with not opening cs:go?

You needed to do all of what i posted. cs:go is that Counterstrike game on steam?

I did and it worked.
And yes, I meant Counter Strike: Global Offensive on steam.
When I press play on steam it runs but only sometimes - mostly its just black screen and closes.

I’m not a gamer but i suspect it’s something to do with the gaming platform. I suggest reading on their forums to see if you can find an answer. You could also mark this post solved and open a post under gaming and ask specifically about CounterStrike on Steam.

Will do. Thanks again!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.