“Launch using Discrete Graphic Card” option missing Gnome Wayland

Yesterday I switched from Fedora 35 (Gnome 41) to EndeavourOS (Gnome 42) on my hybrid graphics laptop (Intel i7 + Nvidia RTX 3050)

Since I booted the live USB with NVIDIA option, the nvidia drivers has been automatically installed on the system, right?

Then, I’ve read on EndeavourOS blog about Optimus-Manager and tried to install it, but then find out that it doesn’t work on Walyand (:smiling_face_with_tear:).

Since I can’t have the Optimus-Manager to switch GPU, I would like to have the “Launch Using Discrete GPU” option when I right-click an application as I had on Fedora… How can I achieve this? I tried installing prime using the nvidia-inst but the option didn’t appeared after that (and even though I can use prime-run firefox I don’t know if it’s effectively working)

What am I missing? How do you manage Hybrid Graphics on Wayland laptops?

Nvidia Wayland support just isn’t there yet. Short answer, it is advisable to stick with Xorg for at least another Gnome cycle or two. Nvidia only just recently enabled Wayland support, it’s not production ready yet. I say this as an optimus user as well. I don’t use Optimus Manager anymore, I use envycontrol but envycontrol doesn’t yet support Wayland yet either. IF you absolutely need Wayland, I’d go to the Fedora 36 beta.

1 Like

I am not sure but this could be a Fedora specific feature that they have added to Gnome. I use it all the time on my nvidia laptop running wayland.

So it’s a GNOME “tweak” that Fedora implemented? And there is no way to achieve it on Arch Linux?
Well in that case I guess I’ll need to stick with prime-run :frowning:

the right click option in Fedora comes from switcheroo-control. That package is in AUR as well.

https://wiki.archlinux.org/title/GNOME/Tips_and_tricks#Launch_on_discrete_GPU

you could check in firefox itself. Open about:support (entered simply in the URL field), and check the “Graphic” section. Your GPU should be mentioned there. When you run Firefox with prime-run it should show your Nvidia card. Without prime-run it should be your Intel GPU.

2 Likes

Sadly, I tried to check what it’s displayed in the about:support page after prime-run firefox but under Graphics>WebGL 1 Driver Renderer it says "Intel -- Mesa Intel(R) Xe Graphics (TGL GT2)", so I gues it’s not working.
Switcheroo-control is installed and enabled but the right click option doesn’t show up too.

I guess I did something wrong in the installation procedure of the drivers… maybe I should uninstall all nvidia related packages and try again? And, in that case, is there a step-by-step wiki page / tutorial that I can follow?

Sorry for my late response.

Well, i just used the Arch Wiki:
https://wiki.archlinux.org/title/PRIME

Have a look at this section especially:
https://wiki.archlinux.org/title/PRIME#PRIME_render_offload

I would focus on getting Prime working first, before fiddling with switcheroo-control