Latte Dock Broken after Kwin QT Update Today

After today’s updates which I saw Kwin and a few QT system upgrades, my Latte Dock starts and then crashes. I have tried reinstalling, using both the AUR and Official version and both do the same. Anyone else experience the same?

Tried running it in terminal, then asked for two missing icon themes back to back, after installing both and running again, I get ‘Segmentation Fault’ error.

[rodney@rodney-mainpc ~]$ latte-dock
Icon theme “Numix-Circle” not found.
Segmentation fault (core dumped)
[rodney@rodney-mainpc ~]$ latte-dock
Icon theme “gnome” not found.
Segmentation fault (core dumped)
[rodney@rodney-mainpc ~]$ latte-dock
Segmentation fault (core dumped)
[rodney@rodney-mainpc ~]$

try another icon theme ?

1 Like

Good suggestion. I am going to have to do some testing. I reverted my system back to yesterday using Timeshift so I am going to wait and see if others have it, or there is a fix on KDE/Latte.

Things I did try;

  1. cleared the .config
  2. changed the latte dock to default using a terminal command, and that worked.

As a result from #2 above, I am guess it is either the icon theme as you suggested, but more likely, I am using ‘Global Menus’ in my latte dock topbar…and there are currently lots of issues reported on KDE with it. I am guessing it is not playing well with latte and the new QT updates that got passed today.

if global menu from kde itself mayby get quicker but if that extentions it 3th party can dure some time

i dont know i just see the drag and drop in xlqt is fixed…if kde itself should be fixed quickly

1 Like

For me Latte Dock works fine, but my desktop shows a very strange behavior after the update. My wallpaper on screen 1 is missing completely, on the screen 2 it is moved to the right. I also can not right click on the desktop, if i do it, just nothing happens.

Yeah, I completely removed latte dock and rebuilt a KDE taskbar, and now it is completely crashing the desktop. I can’t figure it out. It was working fine, but then I went to click on the network icon and it bugged, and now even on reboot…the desktop crashes. I will have to do another restore of my system and just wait.

I don’t use Latte but I have the same wallpaper issue, only it’s missing for me on screen 2. I found out that Fn+F8 ( bringing the monitors display option on my Dell) after boot, and selecting again my configuration (second screen extended display on the right) reset the monitor as it should be, and I regain my normal configuration. But I have to do this after each reboot… Until a fix appears.


Yeah I saw a couple of recent bug reports on the KDE bugtracker site, detailing multi-monitor issue. Sounds like what you describe. Consequently, I am using a dual-monitor setup, so it could all be related.

1 Like

Still works here (being on aur/latte-dock-git). The desktop picture issue is usually KWin getting confused about the monitor setup, happens sometimes.

1 Like

That worked for me, too. Hope a fix will be available soon.

There are some major issues with the QT 5.15.1-1 updates. Manjaro has identified it in their unstable branch, it is all over reddit. The reddit Arch post ’ KDE Plasma broken after last update. for one.

Overall it still works for me, but I saw some minor weird behavior. For example does anybody still see folders on the desktop? They don’t show up for me anymore.

I wouldn’t describe them as major issues, but there certainly are bugs.