Latest update: x264 (3:0.160.r3011.cde9a93-1) error

I see error message to get regular update : x264 (3:0.160.r3011.cde9a93-1) update does not satisfy dependency to continue update it adds that this breaks dependency with libx264.so=154-64 needed for ffmpeg2.8 package.

endeavos@endeavos-inspiron5459 ~]$ sudo pacman -Syu
[sudo] password for endeavos:
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: instalando x264 (3:0.160.r3011.cde9a93-1) se rompe la dependencia con «libx264.so=159-64», necesaria para el paquete ffmpeg2.8
[endeavos@endeavos-inspiron5459 ~]$

The AUR package ffmmpeg2.8 is in need of an update, if you need this for a particular package, then wait with updating or look for another solution.

You can read it over here: https://aur.archlinux.org/packages/ffmpeg2.8/

2 Likes

What needs FFmpeg 2.8 still?

1 Like

Thanks :slight_smile: … I am waiting for now.

I think it is wise to investigate if you really need it, just like @jonathon said.

I was investigating and this is weird… I have both ffmpeg (2.4 & 2.8 AUR) installed… lol I cannot recall what install demanded to install both or why.

[SOLVED]
Just removed a list of orphaned files and among those ones was ffmpeg 2.8 AUR, used cli:
sudo pacman -Rns $(pacman -Qtdq)

And after removing all them including ffmpeg AUR package, I updated and installed those pending 2 ffmpeg files successfully: sudo pacman -Syu
As in the image.

3 Likes