Latest update changed my fonts

Hello forum,

Latest update, from today, changed my system fonts, is this expected?
I tried to the restore the theme through Welcome app to EOS theme, but no joy.


[marcelo@linux ~]$ neofetch 
                     ./o.                  marcelo@linux 
                   ./sssso-                ------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Kernel: 5.9.12-arch1-1 
             `-/ossssssssssssso/.          Uptime: 6 mins 
           `-/+sssssssssssssssso+:`        Packages: 977 (pacman) 
         `-:/+sssssssssssssssssso+/.       Shell: bash 5.0.18 
       `.://osssssssssssssssssssso++-      Resolution: 1920x1080 
      .://+ssssssssssssssssssssssso++:     DE: Xfce 4.14 
    .:///ossssssssssssssssssssssssso++:    WM: Xfwm4 
  `:////ssssssssssssssssssssssssssso+++.   WM Theme: Arc-Darker 
`-////+ssssssssssssssssssssssssssso++++-   Theme: Arc-Darker [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: Arc-X-D [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Terminal: xfce4-terminal 
  `:::::::::::::::::::::::::------``       Terminal Font: Source Code Pro 10 
                                           CPU: Intel i7-7700 (4) @ 4.200GHz 
                                           GPU: NVIDIA GeForce GTX 1660 
                                           Memory: 1047MiB / 15947MiB
1 Like

Possibly due to endeavouros-theming update. Will check this out a little later.

Edit: Mine still is Fira Mono Medium, but I might not be the best candidate to report since I specifically changed the terminal font shortly after initial install.

Thanks sothis6881

Indeed, the theming was updated, and also some fonts.

[2020-12-07T12:45:10-0300] [ALPM] upgraded endeavouros-theming (6.2-1 -> 6.2-2)
[2020-12-07T12:45:11-0300] [ALPM] upgraded noto-fonts (20190926-4 -> 20201206-1)
[2020-12-07T12:45:12-0300] [ALPM] upgraded noto-fonts-cjk (20190409-2 -> 20201206-1)
[2020-12-07T12:45:13-0300] [ALPM] running 'fontconfig.hook'...
1 Like

font look nice :blush:


Yes, this font is not ugly :slight_smile: I could get used to it

1 Like

Did you find a solution? I have the exact problem now. I use the font “Noto Sans Regular” but after the update it looks strange (like on your pictures). I tried to reinstall the fonts but it didn’t help.

Hello Cviper, no solution here…
Still with that strange fonts… but after a few days using it, it’s looking normal for me now hehe

If you find a solution please let me know

I will. I also updated my notebook but everything fine here. Strange that it only affects my desktop system.