Latest update broke G510 keyboard

G510 keyboard worked perfectly, now it just hangs and refuses to work. Need some guidance on how I can figure out which package did this, perhaps revert it.

I know this exists; but I don’t need the fancy leds or the macro’s. Are there keyboard options or konsole commands to reset it?

Did install libg15 the libg15render and g15daemon again, plugged it out and in which fixed it last time, yet no solution.

lsusb does show; the ID with the description Logitech, Inc. G510 Gaming Keyboard, however I can press one button and then it stops or repeats it indefinitely.

Forgot to mention I’m running KDE.

Not knowing too much more have you looked at this?

Yes the more information you provide the easier it will be for someone to help you, I’m no expert but I can occasionally find something that’ll help or rule out other things

1 Like

I did look into that, yet what I don’t understand is that it worked out of the box (latest Endeavor install) and it worked for a while, and now all of a sudden it’s broken. So I’m hoping anyone could point me to the right direction and perhaps have a command to change it into a default / normal keyboard or something, or a location where I can respec it.

Yer its a bit above me without actually having it in front of me, hopefully someone will be able to help you out

Did the daemon not work?

I’ve just deinstalled them and try to reinstall them to see if it makes a difference.

Are you referring to the patches?

I meant libg15 → libg15render → g15daemon → g15stats and to no avail.

You went through the steps to install the libg15 and g15daemon patches as well?

I’m going to try this next, although I might get stuck somewhere down the line, but I’ll try.

Yeah just go through the G510 on g15daemon section of Smokey’s link. Reading through it and it seems pretty doable.