Latest 2019.12.22 iso stalls on Xorg message (virtualbox)

The latest 2019.12.22 iso stalls when I load this.

Here is where my system stalls when launching the ISO in Virtualbox:

Is this a bug within the EndeavourOS latest ISO, or hardware related?

Thanks!

Hi @robinjuste,

if you checked your md5sum ISO, and it’s good, it has to work.

Do you speak french ?

Did you start the ISO in a “bare” (new) VM?

Or did you reuse a existing one and tried to boot the iso and then just install over the existing virtual file system?

Simple question: what graphic hardware? vmsvga or vboxsvga?

Which version of Vbox ?

Yes, this was a bare new install within a new VM.

I’m running Version 6.1.0 r135406 (Qt5.6.2) of Virtualbox.

Okay, I remember that I saw this once when booting the ISO in a VM with an existing installation.
Then tried it in a new VM and the error was gone. So I thought this was linked to that.

Virtualbox needs to be configured to make use of VBoxSVGA + 3d … see here:

2 Likes

Oddly, I got it to finally work with 3D Acceleration disabled.

I have a Asus GeForce GT710 2GB card installed, using Windows 10 for this VM test.

image

with VBoxSVGA in use you can also enable 3d, but current virtualbox is buggy and it gives a warning that you have wrong settings, it also resets graphic controller back to default if you do change something else… you can check this and change it from default window also