Laptop will not boot

Hi all,

My laptop refused to boot this morning.
Nothing fancy happened when I shut it down yesterday evening, no unfinished update or anything else.

The screen says:

Loading Linux linux...
Loading initial ramdisk...
error: file /boot/initramfs-linux.img'  not found.

Press any key

No nvidia.

I chrooted in and reinstalled the kernels, since I have the regular one and the lts installed.
Went without problems, reinstalled grub and updated it, without issues.

But, when I try to reboot it stalls and shows this:

Loading Linux linux-lts ...
Loading initial ramdisk ...

And I have to hard shutdown to exit.

Could someone lead me to the right direction?

Cheers.

You should never hard shutdown. That’s a proven way to very quickly break your system.

Nothing else I could do atm.

Not sure, but could it be that your initramfs are not yet correctly generated?

You may need to chroot again an regenerate them.

What filesystem are you using? Dracut or mkinitcpio?

Dracut.

Personally, I would try chrooting again and regenerate the initramfs.

If you use Grub and eos-dracut, in chroot: dracut-rebuild

Okay, I’ ll try that first.

1 Like
[root@EndeavourOS /]# dracut-rebuild
Failed to build initrds, use "sudo reinstall-kernels" instead
[root@EndeavourOS /]#

So I reinstalled the kernels, but get the same message.

From chroot, post the output of:

pacman -Q | grep -E "grub|mkinitcpio|dracut"

lsblk -f 

cat /etc/fstab

efibootmgr
# pacman -Q | grep -E "grub|mkinitcpio|dracut"
dracut 102-1
grub 2:2.12-2
kernel-install-for-dracut 1.10.1-1
mkinitcpio-busybox 1.36.1-1
mkinitcpio-nfs-utils 0.3-8

[root@EndeavourOS /]# lsblk -f
NAME        FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
loop0                                              
sda                                                
├─sda1                                             
│ └─ventoy                                         
└─sda2                                             
nvme0n1                                            
├─nvme0n1p1                          474.5M     7% /boot/efi
├─nvme0n1p2                             51G    72% /
└─nvme0n1p3                                        
[root@EndeavourOS /]# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=2218-9BA3                            /boot/efi      vfat    umask=0077 0 2
UUID=180cdfdd-3557-4ce8-bfcc-c5abc43b2883 /              ext4    defaults,noatime 0 1
UUID=96ef776b-98cf-42a9-b213-7e7417fae936 swap           swap    defaults,noatime 0 0

[root@EndeavourOS /]# efibootmgr
Timeout: 0 seconds
BootOrder: 0000
Boot0000* endeavouros   HD(1,GPT,b0927490-1f8a-9943-ba48-c4762c82f664,0x1000,0x100000)/\EFI\endeavouros\grubx64.efi
1 Like

If you are using grub, you would need the package eos-dracut.

kernel-install-for-dracut is meant to be used with systemd-boot.

Remove the latter and install the former.

Then try again:

dracut-rebuild

grub-mkconfig -o /boot/grub/grub.cfg

For info on dracut implementation on EnOS:

https://discovery.endeavouros.com/installation/dracut/2022/12/

Also, you may need to remove these if you are not using mkinitcpio:

2 Likes

I installed eos-dracut and it ran the init automatically, without asking. :sweat_smile:
Regenerated grub and it booted again.
Hmm, weird thing, still dunno what caused this.

But thanks pebcak

Edit: same thing happened today.
Strange since I don’t mess around with it just run updates every day…

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.