Laptop does not suspend when lid closes

I have a laptop w/ dual boot, both XFCE (EOS and Mint). I have identical power-manager-settings which say suspend when lid closes. Mint is doing it, but EOS does not.
Just wanted to post that here in case there is some bug.

“Je suis Samuel Paty”

I think there is a setting in power management you need to set.

Hey, I also have this problem! It initially was fine on EndeavourOS and only recently has stopped working. I thought it had something to do with my bspwm / xfce4-session amalgamation, but maybe not…

2020-10-23-161655

I do not believe so: I have identical setting in mint and it works as expected. Another poster also says he has the same issue.

I do not have bspwm. I only have the xfce that came with the distro.

xfce-power-manager and unchecked logind-handle-lid-switch

1 Like

In Xfconf? Seems to be checked for me.

2020-10-23-202455

I’m not that familiar with bspwm. It probably is similar.

Let me clarify what I think you are saying:

In the file ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml you say I should “uncheck” logind-handle-lid-switch. Meaning should set the Boolean to false? It is currently true.

Oh, sorry to confuse - I’m only using bspwm as a replacement for xfwm, everything else is XFCE stuff. So Xfconf should be controlling settings (and was, for a time - it only recently has stopped locking when closing the lid)

I do not think the suggestion is correct. I think the issue is elsewhere.

On Xfce setting editor > xfce-power-manager and uncheck logind-handle-lid-switch.

journalctl --unit=systemd-logind --follow lets me know that it’s seeing laptop open / close events, so that rules out hardware issues.

What seems rather strange to me is that xfce4-power-manager hasn’t had an update in a while. Maybe it’s some unfortunate combination of settings, or maybe another program’s causing this issue.

This issue has come up before. Xfce 4.16 is coming soon. Maybe an update will fix it or someone else has run across it recently. I use a desktop.

Edit: I don’t typically use suspend or hibernation.

Oh, this is my bad! I thought you were asking here if I had logind-handle-lid-switch checked.

Unchecking this setting solves the problem :sweat_smile:

1 Like

Well … Vinay doesn’t think my suggestion is correct? Maybe he try it?
Edit: Sorry the way it was written. Glad it works for you. :slightly_smiling_face:

I just tried it (putting Boolean to false in the location described earlier). Confirming that it does not fix the problem for me.

EDIT: Sorry, the solution proposed by @ricklinux works. I thought it was sufficient to logout to apply the new settings, but it is not. I had to restart and then it works. I also checked my mint file, and the same setting is present there also (ie, Boolean = false).

Thank you.

1 Like