Laptop audio switches to speakers after reboot


I am running latest updated Atlantis Neo (XFCE+QTile) as of today. I have a Dell Precision 5510 laptop.

When I restart my laptop or resume from hibernation, the audio switches to speakers. When I unplug and replug the headphones, it starts working from headphones again.

I was using PopOS 20.04 LTS earlier and did not have this problem so I assume its not a hardware problem.

The volume level also resets to 44% and does not remember the last volume level.

Note: I have run sudo alsactl restore and the problem is not fixed. I don’t know why I ran it. But I have a snapshot before running this command in case I have to revert back.

If you’re running with PipeWire then it could be a media session regression. Try wireplumber instead of pipewire-media-session.

If none of that makes sense, provide the output of inxi -Faz (as text).

Welcome to the forum @Fossworld :tada::balloon:


Hardware.odt (40.0 KB)

  Kernel: 5.15.23-2-lts x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=deba4e48-656c-4fde-b872-52d85a9fe9d7 rw rootflags=subvol=@
    resume=/dev/mapper/luks-8ce56d3d-44fc-4e25-ac6a-630d795e8850 loglevel=3
    nowatchdog nvme_load=YES nvidia-drm.modeset=1
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 wm: LG3D vt: 7 dm: LightDM 1.30.0
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Dell product: Precision 5510 v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 0N8J4R v: A01 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.9.0 date: 10/11/2018
  ID-1: BAT0 charge: 77.0 Wh (100.0%) condition: 77.0/84.0 Wh (91.7%)
    volts: 12.5 min: 11.4 model: LGC-LGC3.67 DELL T453X85 type: Li-ion
    serial: <filter> status: Full
  Info: model: Intel Core i7-6820HQ bits: 64 type: MT MCP arch: Skylake-S
    family: 6 model-id: 0x5E (94) stepping: 3 microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3204 high: 3208 min/max: 800/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3207 2: 3203 3: 3206
    4: 3208 5: 3200 6: 3202 7: 3207 8: 3203 bogomips: 43198
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:191b class-ID: 0300
  Device-2: NVIDIA GM107GLM [Quadro M1000M] vendor: Dell driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:13b1
    class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-12:6 chip-ID: 0c45:6713 class-ID: 0e02
  Display: x11 server: X.Org driver: loaded: modesetting,nvidia
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5")
    s-diag: 1165mm (45.9")
  Monitor-1: eDP-1 res: 3840x2160 hz: 60 dpi: 282
    size: 346x194mm (13.6x7.6") diag: 397mm (15.6")
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.3.6
    direct render: Yes
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
    class-ID: 0403
  Device-2: Realtek USB Condenser Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.1:9 chip-ID: 0bda:4c07
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.15.23-2-lts running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 02:00.0
    chip-ID: 8086:24f3 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-4:4 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: down bt-service: not found
    rfk-block: hardware: no software: no address: see --recommends
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    port: f060 bus-ID: 00:17.0 chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 953.87 GiB used: 633.26 GiB (66.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: THNSN51T02DU7 NVMe 1024GB size: 953.87 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 57DA4103 temp: 42.9 C scheme: MBR
  ID-1: / raw-size: 919.92 GiB size: 919.92 GiB (100.00%)
    used: 633.21 GiB (68.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3ef03486-b442-4d1e-80ad-554ef2352838
  ID-2: /home raw-size: 919.92 GiB size: 919.92 GiB (100.00%)
    used: 633.21 GiB (68.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3ef03486-b442-4d1e-80ad-554ef2352838
  ID-3: /var/log raw-size: 919.92 GiB size: 919.92 GiB (100.00%)
    used: 633.21 GiB (68.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3ef03486-b442-4d1e-80ad-554ef2352838
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 33.94 GiB used: 55.3 MiB (0.2%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-8ce56d3d-44fc-4e25-ac6a-630d795e8850
  System Temperatures: cpu: 73.0 C pch: 63.5 C mobo: 36.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 4083
  Processes: 291 Uptime: 20h 41m wakeups: 1 Memory: 30.86 GiB
  used: 6.96 GiB (22.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: 1324 pacman: 1278 lib: 282 flatpak: 46 Shell: xonsh
  v: 0.11.0 default: Bash v: 5.1.16 running-in: alacritty inxi: 3.3.12

Please find the requested output. I am afraid I don’t understand what to do with wireplumber.


sudo pacman -S wireplumber

and reboot. If it doesn’t work any better then revert with

sudo pacman -S pipewire-media-session

Also you should get into the habit of looking at the Arch wiki, e.g.


Hi @jonathon

I am going to try it on the weekend. Just one question though. To revert back to pipewire-media-session do I need to remove wireplumber and visa versa. Or simply install them.

Thanks for the wiki link. I will go through it.

I have literally written about that in the post above.

This solved my issue with pipewire defaulting to my speakers instead of the headphones I’d set as default after I reboot my desktop… Thanks!

1 Like

Hi just to update:

I installed wireplumber:

sudo pacman -S wireplumber

and rebooted. Unfortunately it did not fix the problem so I reverted back using:

sudo pacman -S pipewire-media-session

and rebooted.

I updated my computer I think yesterday and today I am not facing the problem. I think the update fixed it. Now it remembers the volume level and also that the headphones are plugged in.

1 Like

This is a feature of a cutting-edge rolling release distro. Updates happen, bugs are fixed, regressions can occur.