Language changed after update

Hello! I updated my system yesterday. Update gave an error, something like unable to set locale or something. After reboot, I get message that I have logged in in new language, and offers a chance to change my home folder names to english. (Their finnish now)

That’s not really a problem, but some of my keybindings don’t work anymore. For example I can’t lauch rofi with super + d (I’m in BSPWM).

locactl gives me this, which seems to be ok.

[vmakela@eosbspwm ~]$ localectl
   System Locale: LANG=fi_FI.UTF-8
       VC Keymap: fi
      X11 Layout: fi
     X11 Variant: nodeadkeys

Is there any other place where I change language?


EDIT: If I try to lauch welcome app in terminal I got this:

[vmakela@eosbspwm ~]$ eos-welcome --once

(process:5752): Gtk-WARNING **: 17:41:08.503: Locale not supported by C library.
	Using the fallback 'C' locale.
Unable to parse command line: Invalid byte sequence in conversion input

If I try to lauch rofi in terminal I get:

[vmakela@eosbspwm ~]$ rofi -modi drun           

(process:6728): Rofi-WARNING **: 18:03:06.310: Failed to set locale.

Enter sudo locale-gen to regenerate the locale.


some helpful info on “locale” worth read

" "


Thank you for help. It worked!

1 Like

Please mark PhoenixAwakend’s answer as solution. :+1:

1 Like
[2022-08-03T04:11:04-0400] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew

Also with the updates in case anyone missed it, there was locale.gen.pacnew file, so just a friendly reminder to run pacdiff or eos-pacdiff (or use the Welcome app) to take care of the .pacnew file and possibly any other .pacnew/save files you might have neglected :wink:


Nice and new concept for me, thank you @Scotty_Trees :evergreen_tree: :evergreen_tree: :evergreen_tree: .

I am yet to learn how to use pacdiff and diff, but your reminder will be helpful in learning to try it out.

@joekamprad made a bunch of great introductory videos available on YouTube and he made a great one I used myself to understand pacdiff a lot better here: EndeavourOS pacdiff tool - YouTube

I used to use the Welcome app to handle .pac files, but now I just use the command eos-pacdiff which is what I run whenever I see a .pacnew/save file show up during updates. The video above shows you what to do, but essentially you can View or Skip or Remove or Overwrite these .pac files, by simply typing the first letter like v for view or r for remove and hitting enter.

But in most cases, you want to select View (press v and hit enter when using pacdiff) first to see if you want to merge things or not. For example, I let reflector-simple handle my mirrors, so when I get a new mirrorlist .pacnew file from the Arch repos, I don’t merge that .pacnew file with my file because then I’ll overwrite my own curated reflector mirrors. Typically though .pacnew files you want to view and possibly add the new lines, but it’s a case by case approach, (if you’re ever unsure just ask us!) and with .pacsave files you will usually just want to remove them and not merge them.

Easiest way to remember the difference between the two pac files: .pacsave is not the same as .pacnew . A pacsave file is saving the configuration for a removed package, if that configuration is different than the default (i.e., if it was modified by the user or by the package itself). I think I lost myself and gone on a bit of a rant, but if you have any questions about it all, feel free to open a new post the next time you have to deal with some .pac files :wink:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.