L2TP/IPSec connection established but no internet access

Hello everyone! In my university network everyone has access to university resources like university_name.com main page and our personal account pages where we can see our grades etc, but we have to connect to the VPN server in order to access any resources other than the university’s. I have successfully done so on multiple Windows 7, 10, 11 and Ubuntu machines using mostly PPTP and sometimes the L2TP/IPSec protocol. Recently I have installed EOS on my personal laptop and now I am actively trying to do the same thing. I have installed networkmanager-pptp, networkmanager-l2tp and strongswan packages using pacman and then used KDE’s network manager gui in order to setup connections using corresponding protocols but with no success.

Usually either one of the following events happens:

  1. VPN connection fails to establish because service failed to start.

  2. VPN connection establishes successfully, but nothing changes, I still have access to the university resources, but no access to anything else. Also it disconnects in couple of minutes saying something like “vpn service stopped and failed to restart”.

I would like to use more secure L2TP/IPSec protocol if possible, so I am mainly focused on getting it to work. First, I followed these instructions:


Then I did some research and also tried the following:

  1. Stopped and disabled firewalld service using systemctl.

  2. Stopped and disabled xl2tpd using systemctl.

  3. Stopped and dsabled systemd-resolved and installed dnsmasq.

  4. Used ike-scan to determine phase 1 and 2 encryption algorithms (3des-sha1-modp1024 and 3des-sha1) and set them manually in the corresponding networkmanager gui menu.

I tried each of these changes one by one and all possible their combinations, but nothig changes the behavior described above.

I would happily provide any relevant logs if you can instruct me on how to do it properly.

Thank you in advance for any assistance!