Ksuperkey and xcape both seem to crash my computer when I press the super key

I am not too sure why this keeps happening but when I tried to use xcape so that I can use the super key to launch the start menu, sometimes it may crash if I press the super key.

I tried then using ksuperkey but it seems to be the same case. I am not too sure why this happens?

What exactly happens is sometimes if I press the super key, the entire screen goes blank and it shows systemD’s block, start and some info, something that systemD shows when I boot up the system.

Do you have them both setup to run at the same time? Are you having two nearly identical processes intersecting? It’s like having a Starbucks across the street from a Starbucks. You’re stuck and the whole world just ends.

It sounds like your WM is crashing. What WM/DE are you using?

No I ran xcape on its own, since it started crashing my system I tried then ksuperkey (note that I manually launch this applications upon startup) and then yeah it crashes randomly if I press the super key.


I am using xfce (using the EndeavourOS configuration).