I would very much like to install Korganizer in EndevourOS but can’t seem to make it happen. Can someone help, please?

Welcome to the forum!! :enos: :enos_flag:
Can you give us more details? What method are you using to install Korganizer?
What Desktop Environment are you running?

OS: EndeavourOS Linux x86_64
Kernel: 5.10.90-1-lts
Uptime: 3 days, 1 hour, 13 mins
Packages: 1002 (pacman), 8 (snap)
Shell: bash 5.1.16
Resolution: 1920x1080
DE: Xfce 4.16
WM: Xfwm4
WM Theme: Arc-Darker
Theme: Arc-Darker [GTK2], Arc-Dark [
Icons: Arc-X-P [GTK2], Arc-X-D [GTK3
Terminal: terminator
CPU: AMD FX-8350 (8) @ 4.000GHz
GPU: NVIDIA GeForce GTX 1050 Ti
Memory: 1862MiB / 15988MiB

I tried this:
sudo pacman -Syu Korganizer
:: Synchronizing package databases…
error: failed to synchronize all databases (unable to lock database)

And this:
sudo pacman -S Korganizer
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
if you’re sure a package manager is not already
running, you can remove /var/lib/pacman/db.lck

Trying doing

sudo rm -f /var/lib/pacman/db.lck

This will remove the db.lck file which is preventing pacman to run
Then run

sudo pacman -Syu



to update your system. Finally, run

sudo pacman -S korganizer

to install your package.

1 Like

sudo pacman -S is the proper way to install a package, the other one you listed (-Syu) is used for updating all installed packages. The message about being unable to lock the database makes me think you already tried some other things. I would reboot to “clean” things up and then try again.

1 Like

You can update the system plus install new packages at the same time.

pacman -Syu name_of_package works just fine.


Worked perfect! Man thanks a million!

Nice to hear. Can you mark one of the posts as the solution?

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.