Konsole - bugs or recent changes?

ive been on gnome for a few weeks, but now back on plasma, clean install but i restored most of my settings via a backup
anyway, have there been changes to konsole’s behaviour recently?
i used to be able to drag and drop a command from a text file and konsole would execute it. this has changed, now i must also press enter to execute the command.

secondly dragging and dropping text into konsole now highlights this text, as in as if a text marker has been used on it, this also causes current text and previous text to overlap and look weird and half the previous command is visible and half the new command if you know what i mean

is this new behaviour? if so how do i change it back? or should i not have restored all my settings (by copying over most stuff from .config and .local/share


Maybe you can find if there are any such changes in Konsole’s changelog.

After a bit of googling, I found that there’s a setting that you can tweak for this behavior in Konsole?

Edit > Settings > Edit Current Profile > Mouse >

Are you sure that you weren’t dragging the newline in as well and this is what was causing the command to be executed? I don’t think konsole “executes” things. That is the shell doing that.

I have no idea what you mean actually. Can you share a screenshot?

I didn’t even know that Konsole has this behavior. It seems more intuitive to me for a terminal emulator to paste the file’s path at the prompt when a file is dragged into it. Pasting the file’s contents into the command line when a file is dragged and dropped into it… Isn’t that a bit dangerous?

I thought we were talking about pasting text from a file. For example, open the file in kate and then drag and drop a line from it.

@ anthony93 which setting is that? i dont see anything relating to this?

@dalto, yes im dragging the newline as well, it used to execute the command this way automaticly. now it doesent
a screenshot, ive dragged and dropped ONCE the command ‘sudo nano /etc/X11/xorg.conf.d/99-amdgpu.conf’ - as u can see theres an extra highlighted ‘sudo nano’ there that shouldnt be there

I can’t duplicate your behaviour at all. For me, if I copy a command with a newline, it will be pasted with the newline and executed. That double pasting doesn’t happen for me at all.

However, it seems like the text won’t be highlighted if you disable this option:

If that doesn’t fix it, I would try creating a new user account to see if the problem is still there. If it isn’t, it may be something broken in your config.

As a side note, restoring all the settings from gnome into plasma can cause some strangeness. It can cause the same type of minor issues you would see when running two DEs on the same account.

1 Like

i wasnt restoring anything from gnome, but a backup of my 2-3 week old plasma
anyway, changing that setting (require ctrl key…)changed nothing it still got highlighted, furthermore when i exited nano it looked like this https://i.imgur.com/QRPtmur.png

ill probably do another clean install and not restore anything from backup…

Wait. Hang on a sec. I think it might be a bash feature. Before you reinstall, can you try to run this command:

bind 'set enable-bracketed-paste off'

1 Like

you know, that solved that issue at least! thanks

Something in Gnome must have enabled that setting somehow. Anyway, I’m glad that helps. Good luck!

in fact it solved the newline thing as well, double thanks!

no reinstall then

No problem, man.

is this something that should run at startup btw?

1 Like

After googling around for a bit, I found that this feature is enabled by default as of Bash 5.1

Yes, definitely. Add that command I posted earlier into your .bashrc and it should work. Good luck.


yep it does. yet another thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.