Kmag update incompatible w i3

I use the kde utility Kmag as a screen magnifier. This week an update of Kmag left it unable to deal with multiple monitors, whether bc of a different monitor resolution or just being more than one monitor.

The puppy on my higher res monitor is garbage, flashing, blocky over-magnified garbage.

I installed kde plasma on a hunch. Kmag works swell on this kde, but, back on or, the same garbage behavior is happening.

I wrote this in hopes that someone may add some insight into this situation. Kde has taken over my system in ways that are unwelcome to me. For example, application windows now display faveicons. The boot process hinges now on kde’s process. But apparently this problem of mine is not due to a missing library, as it is unchanged.

Anyone?

Alan Davis

By the way, I have downgraded Kmag, and now it works fine. The package manager of Kmag has not responded.

Alan

First of all welcome here! :enos:

As far as i understand you … you are running i3-wm installed with EndeavourOS configs using kmag as magnifier tool?

As you say:

What needs some better info on what exactly you want to say with it…

same for this:

And using tools from DEs in i3-wm can cause some issues i would have a look on other tools to see if they do work for you like:
https://aur.archlinux.org/packages/magnus

install it from AUR with yay like so:
yay -S magnus

1 Like

Thank you. I will check out Magnus.

However, in years of using i3, I can think of no other such incompatibility.

About Kde taking over: several thinks I noticed.

  • problem switching back to i3.
  • the DM of kde took over from lightdm
  • suddenly an application window on i3 has a faveicon. So it seems kde puts it’s stamp on i3.

These are troubling. I have no probs, in the past, with other kde applications, as long as libs are present. For many years, kde has been problematical for me due to complexity of dependencies. When I was runng Gentoo, every few days came up a tangled upgrade dependency hell, and hours of kde library recompiling that often failed. So, as good as some of the tools (like Kmag), are, and as polished as the environment is, it is unacceptable, too slick, full of itself and uncooperative.

i3 is just okay by me.

The developer of the arch package has not responded toy query. In passing, I saw another post, don’t know which gnuLinux, has the same exact issue with Kmag, and solved it by downgrading Kmag.

Alan

1 Like

Following up on the respondent’s question. I am using i3, on Endeavour OS. However, I have over-ridden the i3 configuration to conform with past experience with i3.

I have installed magnus. Kmag is far and away the better application. I’m sorry I cannot remember what, but somehow magnus had at least one issue, in so far as starting it up. As usual, I find KDE to be an overbearing environment, but some of the individual applications to be the best I have found. I shy away from KDE Plasma as a desktop, but for MOST purposes, there are no problems mixing libraries; I use some gnome-based applications, or XFCE4. This should work, of course, it is the Unix philosophy.

Thank you for the response. No idea yet what is the problem.

Alan

I would not know of that this will happen without setting it manually.

This will be an qt application? and it is using qt design?

There is a lot changed on kde/plasma over the last time

I do not wish to learn KDE, so I don’t know how to navigate these changes. It seems draconian, to lock users of the utilities into the entirety of KDE, if that is what is happening. Maybe it will shake itself out.