Keyboard layout doesn't switch

Hi, couple of days ago I clean installed EOS using offline installer but for some reason, when i add keyboard layouts it doesnt work, shows in setting but i cant change it (i tried xfce applet, and keyboard bind i defined)


image

the only way i can make it work is using these commands

setxkbmap -layout us,ir
setxkbmap -option 'grp:alt_shift_toggle'

@rootiens
Are you trying to set it to US? Turn on system defaults toggle at the top right work?

1 Like

default is US, im trying to add ir/persian.
yea it does

Are you saying that worked for you?

1 Like

If you toggle the switch on top right (Use system defaults), and back again it should then work as expected.

2 Likes

i said that worked because when i add other layouts with command, and i switch to default system, only US works

i had to logout once, its working now

I have also encountered this bug, and toggling the “Use system defaults” on and then back off worked with no need to logout/login.

But I think this should be fixed so that it’s unnecessary to do this additional arcane step… It works as expected in Manjaro…

1 Like