Keyboard cannot navigate installer

Hey there flashed the latest installer of endavouros from Windows. Rebooted into the USB and my corsair strafe keyboard will not work. Or mouse if that’s supposed to either.

But I can’t install because my keyboard isn’t inputting. My keyboard clearly works and I tried replugging with no success

Did you try plugging your keyboard and mouse into different USB ports? Sometimes a PC will have multiple USB controllers and one of the controllers isn’t recognized by default.

So when booting into the USB and the modern gui it wouldn’t work

However I then booted directly into the partition alinto a basic interface and that worked with it?

Huh??

There may be various reasons for this, e.g.
https://discovery.endeavouros.com/installation/create-install-media-usb-key
Also secure boot should be disabled.

If your bios allows it you can try to set the USB to version 2.0 (or plug the stuff in to 2.0 ports if you have any), the issue is probably related to the driver. Avoid using usb hubs just in case.
If you can provide us your motherboard name/version/revision we might might be able to figure out why is it acting weird