Keyboard and Touchpad not working on Live installer (Aspire E5-511G V1.10)

Hello! I recently discovered EndeavourOS and it’s exactly what i’ve been looking for, I went straight for the download and flashed the iso on my USB using etcher, everything was going smoothly until i booted into the live desktop, after that i just couldn’t do anything, Touchepad was not working, nor was the keyboard, I had a spare mouse and it worked after i plugged the wireless USB for it, as for the keyboard there was no way i could get it working. i have no idea why this is happening but it could be that some drivers are missing? please have it fixed as soon as you can! Again a big thank you for all of your efforts.

Ps: my PC is Acer Aspire E5-511G V1.10

Welcome aboard!

That’s a strange one, as the necessary drivers are there; I suspect something else is at issue.
A quick search reveals others with Acer laptop keyboard problems

So I would firstly suspect the ribbon cables attaching the keyboard/touchpad to the mainboard.

Have you tried another distro?

Have you got a USB keyboard to put on it for the moment in order to do some more diagnosis on the terminal, eg dmesg -T and journalctl -xe ?


I have an eleven-year-old Acer Aspire that runs Endeavour that I mainly use for watching Netflix and other streaming services in the bedroom.

As the link @onyxnz already provided, shutting down the laptop, remove the battery and leave it for 15 minutes, then put the battery and the power cable back in place and your laptop should be running without an issue. It is a weird Acer issue that comes back once in a while.