Kernel panic during update / issues with pacman sysroot

This is normal in chroot. It has no relevance.

If you need to reinstall all your packages, then yes:

pacman -Qnq | pacman -S -


pacman -S $(pacman -Qnq)

The -S option preserves the installation reason by default

as per ArchWiki link you posted.

1 Like

Does pacman -Qnq return a list of all your packages? Depending on the state of your database it is possible it no longer knows what packages you have installed.

1 Like

Yes, that’s looking good. Will try to get the keys working later tonight and then attempt the reinstall of all packages.

So, pacman-key --init showed another missing dependency, sqlite.
After that, pacman-key --populate ran fine (appending keys from archlinux.gpg and endeavouros.gpg) but pacman-key --refresh-keys is causing issues, full of errors/failures:

[root@EndeavourOS _repair]# pacman-key --refresh-keys
gpg: error running '/usr/bin/dirmngr': probably not installed
gpg: failed to start dirmngr '/usr/bin/dirmngr': Configuration error
gpg: can't connect to the dirmngr: Configuration error
gpg: error retrieving '' via WKD: No dirmngr
gpg: error reading key: No dirmngr
gpg: error running '/usr/bin/dirmngr': probably not installed
gpg: failed to start dirmngr '/usr/bin/dirmngr': Configuration error
gpg: can't connect to the dirmngr: Configuration error
gpg: keyserver refresh failed: No dirmngr
==> ERROR: Could not update key: A6234074498E9CEE
... same ERRORs for all other keys

It seems like dirmngr is part of gnupg which was one of the first packages I fixed as recommended by dalto quite at the beginning.

[root@EndeavourOS _repair]# dirmngr
dirmngr: error while loading shared libraries: /usr/lib/ file too short

libldap is one of the dependencies of gnupg. So installed that one as well, and now it works. :raised_hands: Feared for a moment that I might have to fix all dependencies which would be quite a few :sweat_smile:

Then pacman -Syu… looking much better now, but still

... all the boring stuff ...
(10/10) checking keys in keyring                                      [---------------------------------------] 100%
(10/10) checking package integrity                                    [---------------------------------------] 100%
(10/10) loading package files                                         [---------------------------------------] 100%
(10/10) checking for file conflicts                                   [---------------------------------------] 100%
error: failed to commit transaction (conflicting files)
chromium: /usr/bin/chromedriver exists in filesystem
chromium: /usr/bin/chromium exists in filesystem
... more chromium/yay warnings ...
yay: /usr/share/man/man8/yay.8.gz exists in filesystem
yay: /usr/share/zsh/site-functions/_yay exists in filesystem
Errors occurred, no packages were upgraded.

:point_right: So, going for pacman -S $(pacman -Qnq), but also getting lots more ... exists in filesystem and the same Error at the end. Should I go for --override or is there another option? Will research more later, but :pray: for any hints.

That would be --overwrite '*'.

This should normally be used “moderately” but as a last resort, in your case, it should be fine.

1 Like

Wow, done, restarted, and back in my system without any chroot or other shenanigans. Things seem to be working fine :sunny: big thank you for all the help @dalto and @pebcak :pray:

Considering all the chroot specific messages during package installs, is there still anything I should be doing now that I am back into my system?


That’s great!

I have to congratulate you for persevering through the whole recovery process.

At the moment the only issue that I should think would need to be addressed seems to be the one you posted on pacman-key --refresh-keys.

To be frank, I don’t have the sufficient know-how for fixing this one. Hopefully @dalto or other knowledgeable fellow forumers will chime in here.

You could also consider creating a new thread with a proper title to attract the attention of members to this issue.

oh, but that’s already been solved by

Anyways, will mark this one as solved and go with some more specific follow-ups.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.