Kernel panic at GRUB bootup -- solved

After trying repeatedly to use the live USB install to correct my damaged grub setup, I discovered a simpler way.

While running Mint, I found the grub.cfg file in EndeavourOS. (After all, it does boot EndeavourOS.) You know, the file you’re not supposed to edit? And I edited it, copying the working Endeavour menu entry and putting that into my non-working Mint grub.cfg. Of course, I commented out the broken Endeavour entry.

I rebooted running fsck once and tried again. Yay! EndeavourOS boots again using the dreaded Mint grub! No kernel panic.

If you will be leaving Mint’s Grub to boot your EnOS, the next time there is an update to its grub, it’s grub.cfg will be overwritten resulting again in a “broken” EnOS boot entry and kernel panic when trying to boot up EnOS.

The better solution would be to let EnOS’ Grub in control of the booting.


It is not so much that grub.cfg should not be edited, as that it will not STAY edited (as mentioned above). Only a few distros can correctly handle an Arch style entry, one of the reasons for the recommendation to have EnOS handle the grub (for for my recommendation of rEFInd :grin: )


Will Refind work on a legacy BIOS system? I don’t have EFI.

Once back in EnOS, I had it redo the grub system correctly. Obviously, I can’t let Mint touch my grub setup. This issue was actually caused by a new install of another distro which is not Arch-grub friendly.

No - it can be sorta configured to work, but not guaranteed, nor worth it. Although, if you remove os-prober from all but EnOS, you cut down on the troubles the others can cause (they won’t know about EnOS). You might still have to access the ‘which boots first’ order occasionally, but that’s all.

1 Like

The fundamental component that most distributions miss when they locate and attempt to reference EndeavourOS is the initrd line, namely this:

	initrd /boot/intel-ucode.img /boot/initramfs-linux.img

Most boot loaders fail to include the /boot/initramfs-linux.img, including only /boot/intel-ucode.img. If you create your own 40_custom grub section and include this, you can get it to work on other distributions.

Yes but for those not using an Intel it would include amd-ucode.img

Yes, you’re right; clearly these are architecture-dependent images, another reason that it’s probably best for the vast majority of people to either chain load boot their systems or boot directly from Endeavour OS. Even if they chain load, they still need to use the correct images, so the recommendation makes good sense.