Kernel 6.1+ freezes on Login Prompt

Hi all, I’ve filed this to bugzilla but the good people over there have too much to do to help me iron this out further and recommended I figure out exactly which subsystem is suspect before posting there. If this post looks familiar, you probably saw it on Reddit where nobody actually responded.
I’m having an issue with any kernel newer than 6.0 - my entire boot process simply freezes up at or very near to ‘reached target login prompt’. I tried booting in runlevel 3 and it froze as it loaded the login text, which makes me think the login prompt is what’s freezing - is this what the bugzilla devs were looking for? This happened a month ago when I was trying to install Fedora as well, but I’m currently running Endeavour and hoped you guys could help. kernel 6.2 hasn’t fixed it either, and this only happens on a specific (somewhat old) laptop that I’ve set up for doing my school work on.
What should I do next?

EDIT: not sure why but a guitar tab I was working on somehow pasted itself in here. Just removed it.


A good start would be to give some information about your hardware, DE, login manager and also maybe your journalctl output in the relevant timeframe before the freeze.

1 Like

You should use an older kernel with older machines, it might be something that won’t get fixed anyway.

have you tried switching to an LTS kernel? Older machines are not targets of newer OS’s and rolling release.

System info:

Currently running KDE but this has happened with an XFCE install of Endeavour as well. I don’t know how to check what login manager I’m using, but isn’t that a GUI front anyway? The bug persists when booting into the multi-user interface (runlevel 3), is the login manager still relevant then?

I can run the boot again and find the journalctl, but I won’t be able to until later tonight.

That’s what I’m currently doing, but multiple people have told me I should try and figure out the bug anyway in case it is fixable. Community effort and all that. Besides, it’s getting kind of annoying to roll back my kernel every time I run updates and I haven’t yet heard of a kernel package that just doesn’t update. I’m open to advice on how to do that.

I’m currently running the LTS, but as of a week or two ago 6.1.7 is the LTS, so I’m stuffed anyway.

I get that rolling releases aren’t ideal for older machines, but as I told mihalycsaba, I’ve been told I should try to figure the bug out anyway… And I love the simplicity of Arch systems too much. Haven’t found anything else that feels the same (that Fedora Kinoite installation looked a little promising, but then it was running the 6.1.7 kernel…)

Your swapfile is relatively small with 512MB. Could you try to make it a big bigger and see if the problem is still persistent? And indeed, if it’s independently on the login manager, this info is not really relevant.

Here’s the journalctl info, as promised…

How big should I make the swapfile? iirc correctly I didn’t change any of the default partition, etc stuff on this install, so it should be the default size.

Probably it’s not the swap size. So you did try on Fedora and the same problem? If yes, it’s probably kernel or some driver not working. Maybe try lower runlevels, see if it lets you login. Runlevel 2 should be without networking. Try a reinstall without modifying anything if you still want to use a rolling distro.

Did you try to boot the latest live iso? Does that work?

Most distributors recommend for your 4GB memory a swap file that equals the memory. So, about 4GB. If you have the disk space and it’s easy to change you can give it a shot.

I think you have either a driver that is not configured properly or you could have a piece of hardware that is beginning to fail. Since you stated it happens with Fedora as well I’m leaning toward a hardware problem and not a software issue.

1 Like

Runlevel 2 doesn’t seem to exist. As for the latest ISO, I haven’t tried, but ISOs running the 6.1 kernel freeze as well. That’s actually how I ended up on Endeavour instead of continuing to use Manjaro like I had been for a bit (no complaints about that happy accident).

Ok so we may have made some progress here, but I can’t be sure… I’m running into a “failed to mount efi” error at boot now. I know I’ve had this error before but iirc I finally fixed it by just reinstalling… Examining my systemd options shows that it doesn’t seem to have updated since the main kernel updated to 6.2.2. I have an entry for 6.2.1 as well as a linux-zen entry which I uninstalled recently due to it not fixing this thread’s problem. I found the efibootmgr page on the arch wiki but I don’t quite understand what I need to put into it, the documentation is very sparse. Can anyone explain how to update/reconfigure systemd to recognize my current kernel options?

Is the message “failed to mount /boot/efi”?

Can you check the output of systemctl status boot-efi.mount?

Did you reach this state after enlarging swap?

Yes, this is after enlarging the swap, and yes, that’s the message. I can still boot using the LTS 1.5.15 kernel that’s installed, so that’s what I’m currently in… Output of the command is Unit boot-efi.mount could not be found.

Do you want me to run it from the emergency mode of the 6.2.2 boot?

And I still don’t know how to refresh systemd to reflect what I actually have installed for kernel options.

Try runlevel 1, just out of curiosity .
After that, try the latest live iso, but set the uefi to boot in legacy (bios) mode. Maybe you have some weird uefi issue.


Are you running systemd-boot as bootloader?

That was my idea, but if that unit doesn’t exist, it probably doesn’t exist with the 6.2.2-kernel as well.

You can show the loaded kernel modules with lsmod, if that was your question regarding the kernel.
Or, if you meant that systemd-boot is not showing all your kernels, and you want to update the bootloader it would be sudo bootctl update.
For systemd-boot, see also:


Could you give the exact messages? Preferably from journalctl, if not possible by taking a picture or such.

Besides that: How old is your computer? I mean, it indeed looks a lot like missing hardware support on the new kernel, but from some googling, I came to the conclusion that your laptop is not super old… I mean, linux is usually not dropping support for around 5-7 year old hardware

From everything in this thread, it seems like kernel 6+ might have removed support for a hardware component (board chipset, bridges … etc). Or it might be not compatible with the uefi system of your motherboard. That might cause the freeze when booted using a 6+ kernel.

1 Like

Mounting /efi...
mount: /efi: unknown filesystem type 'vfat'.
dmesg(1) may have more information after failed mount ...
efi.mount: Mount process exited, code=exited, status=32/n/a
efi.mount: Failed with result 'exit-code'.
Failed to mount /efi.
Dependency failed for Local File Systems. Job failed with result 'dependency'.

Yeah, this laptop is old but it’s not ancient. That’s why I haven’t really given up on it yet.

I don’t honestly think the problem has anything to do with the journalctl info, though… This is the systemd screen I was talking about;

I don’t have linux-zen installed anymore, and the standard arch kernel should be 6.2.2 at this point. This leads me to believe systemd isn’t recognizing my actual kernel options and is still stuck somewhere before a recent package update. Does anybody know how to fix that?

I ran sudo bootctl update and it still shows this.

P.S. to everyone else offering solutions… I much appreciate it and fully intend on attempting what you are suggesting, but I want to make sure I’m booting the kernel that’s actually installed first.