Kernel 5.4.12 and an error in welcome

Hello everyone,

after a short test period i have to admit that endeavourOS is great! It replaces Windows 10 completely and additional to that i can learn something about (arch) linux - quite excellent.

When do you release kernel 5.4.11 and 5.4.12? Do you manage this kernels for us or do that archlinux? Or don’t the new kernel versions bring new features or bugfixes? Sorry i don’t know a lot about the kernel or other stuff of linux.

A short error which occurs sometimes: i boot up the system and then welcome opens automatically. I push on “system updates” and it answers no updates. Two seconds later the system or welcome reports two new updates. When i try to install them it fails because of su and not eligible rights. So i have to do it via console and sudo pacman -Syu.

Just as a report from me. No intention of making stress.


Hello @Endlich
As stated on the Welcome to EndeavourOS home page.

With the exception for our in-house developed reflector-auto, eos-welcome and the eos-update-notifier, all the packages are directly installed from the Arch repos or the AUR, so there are no customized or modified packages coming from our own repo. We want to stay as close to Archlinux as possible.

When you first boot the Welcome screen comes up. From there you can update your mirrors first. Then you can use detect system issues and it may remove a few packages not required for your hardware. When first installed it will be right up to date. There is a possibility that the odd updates happen at the time of your install so you may see a notification that there is an update or two. You can use the update system on the welcome screen to check for updates or use the terminal. When you use the the welcome screen to check for updates and install them it does require your password the same as using the terminal.

Edit: Keep in mind this is a rolling release so updates happen frequently.

It might help if you delay the starting of the welcome app a bit.

Look at file /etc/xdg/autostart/welcome.desktop.
At line 6 there’s the Exec=… thingy that starts the welcome app.
Give the --startdelay option a bigger value (it is in seconds). Now it is 3, but for example value 5 could make a difference. This value probably is dependent on the speed of a machine, so adjusting may be needed.

And please report here if it helps. That will help developing the app.

@manuel Thank you for your help.

I have the problem now, that i can’t save the text file to the welcome.desktop file. There is always an error saying that it couldn’t save the file for writing or something like that.

How did you try to edit it? I use nano.

sudo nano /etc/xdg/autostart/welcome.desktop

To save i use ctrl o plus enter
Then to close ctrl x

Or i think you can just use ctrl x to do both.

I updated my mirror list. When i try to detect system issues there is the following error:
su: Authentication error
Please push enter to close this window

The same error i get when i try to update my system through welcome. Then i have to go to the terminal and do it there. There it works without any problems.

Thank you Rick for your tip with the nano, i tried to open and edit it with leafpad.

leafpad is good too…i’m just used to nano. When you installed Endeavour did you check the box to use same password for both user and root?

You could try going to root first.
nano /etc/xdg/autostart/welcome.desktop

Then make the changes and save and exit.

Yes this works, thanks.

And yes i use no password just push enter for user and root. Is there a problem?

I’m not sure if that is such a good idea. It would be much better to have a root password. I use the same for both on my home computer. I’m not sure what you did on the install and if you didn’t set it to use the same the default may be root? Maybe @manuel can answer that?

Edit: So what you are saying is you used enter for the password? Did you check the box to use the same for admin privileges?

Not sure what @Endlich meant exactly.

The general rule is use a non-root account for any normal use. That is, practically always.

If some things need elevated permissions (like installing packages, or writing to system files), then there are some choices how to get those permissions, like:

   sudo some-command
   su -c "some-command"
   pkexec some-command

The some-command above means a full command, including its parameters.

   su -c "leafpad /etc/xdg/autostart/welcome.desktop"
   sudo leafpad /etc/xdg/autostart/welcome.desktop
   pkexec leafpad /etc/xdg/autostart/welcome.desktop

All of the three alternatives above open that file using elevated permissions. Without those permissions saving the file is not possible.

I think when he installed endeavour his password is just enter and i’m assuming for both?

Yes exactly.
Should i re-install the os again?

No you just need to set password for root and user. I’ll let @manuel give you the instructions as he is the expert. :grin:

Ok, with help of


i put in a password for root. Do i need a separate password for the user account, too?

EDIT: I don’t know if this helps but my login is needed now for starting up the system, too. So i guess everything is alright now?

But my problem with

su: Authentification error

still exists and that for system update and Search for system problems.

Yes you need a a password for both root and user account. They can be the same if you like. Are you not able to switch to root?

To change your user account password.

passwd username

Enter your current password and then change it.

Then after you need to be root in order to change the root password.

Either su and enter or sudu su


Then enter your current root password and then change it.

Please be careful because you do not see the characters you are entering so if you make a mistake then you won’t have access because you won’t know what you typed in. If this doesn’t work you may need help from @manuel

Edit: I’m not sure what your current root password is because you just used enter when you installed and i don’t know whether you checked the box to use the same password? I’m not sure whether it even accepts enter as a valid password for root?

I did checked the box for both users have the same password. When i created a password for root, the password is the same as for my user account. I could change the passwords, it works now. Thank you again!

1 Like


I just want to tell you that since the latest Welcome update(s) the error is gone, finally. :slight_smile:

But how can i change the kernel from 5.4.14 to for example 5.5.0-rc7? And how does i get updates for kernel then? Still through Welcome i don’t think so, right? I have to put the updates for kernel on my own right?

Thank you guys. :+1:

Arch devs do not release rc kernels AFAIK. But there is linux-mainline in AUR, although I don’t recommend using that. And it may be a challenge to get it work.

1 Like

I see. Thank you. I will stay with the released kernel.