Kernel 5.11.2 upgrade freezes at KDE startup [Solved]

I tried upgrading to kernel 5.11.2 and the system hangs at the KDE splash screen. After the hang, it doesn’t respond to Ctrl Alt F2 or any other combo to get to the tty.

Here’s the output of my inxi -xFz for hardware details.

System:    Kernel: 5.10.16-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.21.1 Distro: EndeavourOS  base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: X470 Taichi serial: <filter> UEFI: American Megatrends v: P3.90 date: 01/10/2020 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K540/K545 charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Info: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 rev: 0 L2 cache: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 182519 
           Speed: 2821 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 2821 2: 2188 3: 2201 4: 2212 5: 2493 
           6: 2125 7: 2126 8: 2208 9: 2195 10: 2205 11: 2197 12: 2195 13: 2127 14: 2197 15: 2199 16: 2200 17: 2200 18: 2200 
           19: 2197 20: 2197 21: 2201 22: 2196 23: 2203 24: 2210 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel 
           bus ID: 10:00.0 
           Device-2: NVIDIA TU104 [GeForce RTX 2080] vendor: ZOTAC driver: vfio-pci v: 0.2 bus ID: 11:00.0 
           Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa 
           resolution: 3840x2160~60Hz 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.40.0 5.10.16-arch1-1 LLVM 11.1.0) v: 4.6 Mesa 20.3.4 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel v: kernel 
           bus ID: 10:00.1 
           Device-2: NVIDIA TU104 HD Audio vendor: ZOTAC driver: vfio-pci v: 0.2 bus ID: 11:00.1 
           Device-3: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 13:00.4 
           Device-4: Corsair CORSAIR VOID ELITE Wireless Gaming Dongle type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 1-1.4.1:10 
           Sound Server: ALSA v: k5.10.16-arch1-1 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: d000 bus ID: 08:00.0 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: c000 bus ID: 0a:00.0 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: bridge0 state: up speed: 1000 Mbps duplex: unknown mac: <filter> 
           IF-ID-2: vnet0 state: unknown speed: 10 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus ID: 1-9:8 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 6.08 TiB used: 860.42 GiB (13.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB temp: 40.9 C 
           ID-2: /dev/nvme1n1 vendor: HP model: SSD EX920 1TB size: 953.87 GiB temp: 32.9 C 
           ID-3: /dev/sda vendor: A-Data model: SU800 size: 953.87 GiB 
           ID-4: /dev/sdb vendor: A-Data model: SU800 size: 1.86 TiB 
           ID-5: /dev/sdc vendor: A-Data model: SU800 size: 953.87 GiB 
           ID-6: /dev/sdd type: USB vendor: Sabrent model: SABRENT size: 465.76 GiB 
           ID-7: /dev/sde type: USB vendor: SMI (STMicroelectronics) model: USB DISK size: 58.05 GiB 
Partition: ID-1: / size: 110.04 GiB used: 41.44 GiB (37.7%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 1.46 GiB used: 280 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p1 
           ID-3: /home size: 128.77 GiB used: 79.25 GiB (61.5%) fs: ext4 dev: /dev/nvme0n1p3 
Swap:      ID-1: swap-1 type: partition size: 13.86 GiB used: 18.8 MiB (0.1%) dev: /dev/nvme0n1p4 
Sensors:   System Temperatures: cpu: 49.2 C mobo: N/A gpu: amdgpu temp: 43.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 694 
Info:      Processes: 473 Uptime: 8h 58m Memory: 31.34 GiB used: 20.21 GiB (64.5%) Init: systemd Compilers: gcc: 10.2.0 
           clang: 11.1.0 Packages: 1808 Shell: Bash v: 5.1.4 inxi: 3.3.00 

Any help to solve this issue is appreciated. As of now, I have marked linux and linux-headers packages to not upgrade via pacman.conf file.

If 5.10.19 and 5.11.1 work then it’s likely a regression in 5.11.2.

If this is the case, you can wait for 5.11.3 and see if that’s better, or attempt a kernel bisection to identify the commit that caused the issue, and then report it to the kernel developers.

There are only 12 commits in 5.11.2 over 5.11.1:

It works fine on 5.10.19. How can i get 5.11.1?

Not sure how to do a kernel bisection, but will be something interesting to do. Thanks for the suggestion.

Edit: Tried 5.11.1 too and it fails on it. So, looks to be an issue with the 5.11 kernel

Do you do your updates via TTY or by a GUI in KDE? What I had to do with the update to kernel 5.11.x is install the update via TTY and do a reinstall of the nVidia driver before I did a reboot.

1 Like

I do it via tty and I use an AMD card.

What is the journal saying when it freezes?
Or Xorg.0.log?
Or $HOME/.xsession-errors ?

Does it only happen with KDE? Can you try a different DE?

Your hardware shows an Nvidia card also using vfio-pci which is a PCI passthrough so as @linesma was pointing out to reinstall nvidia drivers via tty.

I have no nvidia driver installed on my host Endeavour system. During boot, the nvidia card is tied to vfio driver and is not available to the host anyways.

Somehow, now everything works on 5.11.1 and I upgraded to 5.11.2 and even that works. No idea why it didn’t work earlier :slight_smile:

1 Like