KDE Wayland issues with the EndeavourOS apps

Have been trying out Wayland on KDE Plasma 5.23.3, and overall it has been a very pleasant experience.

One bug is that with all the EndeavourOS apps, the cursor switches from Breeze Snow (which I have chosen) to Adwaita. This is a bit odd as my few other Gtk apps don’t have this issue, so I haven’t been able to identify a fix. EDIT: solved thanks to @joekamprad below.

Secondly, pressing the “Don’t show me anymore” button on the Welcome app does not produce the popup window that appears on X11. The button stays selected, and attempts to close the Welcome app window cause it to freeze:

Pressing the button does toggle on and off the autostart of the Welcome app, however.

Reboot, that cursor thing should be usual KDE problem when switching themes, but i’m not sure…usually reboot fixes it

It persists after multiple reboots :frowning_face:

Looks like one of those plasma/wayland problems.
As far as I know, the workaround is to use x11 instead of wayland.

My workaround for now is to put up with it as the issues in Wayland for me are minor:

I’m flagging this up because it is only the :enos: apps that have these issues - my other Gtk apps are working fine.

the solution is to set default xcursor-theme:


[icon theme] 

That’s it :+1: In my case I’ve used:
[icon theme]

That leaves the issue with the “Don’t show me anymore” button on the Welcome app, but I suspect that one is more complicated.

Thank you.

yes i checked this too… but there is no log to output i can see while it happens… it only causes welcome app window to freeze.

1 Like

I looked around, and the problem seems to be wayland does not support the protocols what yad uses with the notebook feature. Welcome is built on yad’s notebook.

So no easy fix is available, unfortunately. Will have to think about possible future solutions.


OK, at least we have identified the problem.

Is it worth updating the Known Issues in the Wiki article on Welcome to reflect this?

1 Like

Added a note about this issue in the Welcome wiki article.

1 Like

Thank you. All the tabs and all the other buttons I’ve tried so far work OK - it’s just the “Don’t show me anymore” button. So it’s mostly usable on Wayland.

Yeah, I tried that here as well. It is quite annoying, but fortunately not fatal.
(Welcome can be disabled with: eos-welcome --disable).

I made some small experimentation with implementing Welcome without the notebook feature. The experiment still needs to be tested in a wayland environment. If the results are OK, I might start going that way, although there’s lots of work ahead.

Without the notebook feature (=essentially the tabs) Welcome will be more cumbersome to use but hopefully working.
And I don’t think it would make it to the next ISO, but maybe later, we’ll see.

1 Like

OK, thank you :smiley: I wasn’t expecting a quick resolution given the nature of the changes needed.

Happy to help with testing whenever it reaches that stage.

1 Like

I’m going to mark this as solved now, as the problem has been identified, and there is a workaround.

All the other functions of Welcome appear to work under Wayland, but do not click on the “Don’t show me anymore” button. Instead, close the Welcome app and then run eos-welcome --disable in a terminal.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.