KDE plasma x11: can't change screen resolution AMD iGPU laptop kernel 6.3.9 / broken sddm 20.0 (asus g14 2022)

first problem

Hello, i just updated my asus g14 2022(amd cpu 6900hs + gpu 6700xs) to latest kernel 6.3.9-arch1-1 and while previously i could set the 2k built innmonitor down to 1080 now in the display configuration settings it only allows native resolution

system is kde plasma on endeavourOS
error message while hovering the info symbol in the display settings resolution voice for built in monitor:

2560x1600 is the only resolution supported by this display.

Using unsupported resolutions was possible in the plasma X11 session, but they were never guaranteed to work and are not available in this plasma wayland session

the output of $XDG_SESSION_TYPE is x11

i’m on xorg x11 but from the error message above it sounds likes plasma thinks i’m on wayland?

I log in with the same entry voice (plasma X11) as before.

Do you have any idea why this is happening and how to fix this? I’m scratching my head on what could have broken this.

I read that SDDM and mesa got possibly upgraded too?

Tried downgrading mesa and lib32-mesa and it didn’t fix this.

can’t really read well text on a 14 inch with 2k res and scaling things is a hassle for everytime i have to connect external monitors.

Second problem that started happening:

Before the last updates i was using tmux with tmux/continuum and tmux/resurrect.
In zshrc i had export XAUTHORITY=~/.Xauthority
never had any problem but now all of a sudden when i open tmux and it restores previous sessions after a reboot for some commands i get INVALID MIT-MAGIC-TOKEN and can't open display:0 (same commands work fine outside tmux) commands include a simple redshift -PO 4000

if i unset the xauthority env i get authorization protocol needed but not specified

TYVM in advance for the help

Pinpointing the updates and the relevant ones could be:

new linux kernel (6.3.9 which contains the APU driver for amd since i’m running integrated mode and only have the iGPU on)

sddm (downgrading this solves problem #2)

mesa updates (downgrading this does nothing)

vulkan-radeon updates.

i’m more inclined the problem lies in the new kernel but is it safe to downgrade to try?

SOLVED: kernel 6.3.9 breaks X11 resolution options for amd iGPU on ryzen laptops (ryzen 6900hs) not allowing to change resolutions on plasma x11 for built in screens (zephyrus g14 2022).
downgrade to 6.3.8

SDDM 20.0 breaks MAGIC TOKENS XAUTHORITY in ways i don’t understand (can’t restore tmux after reboot as i can’t run commands like redshit, x11 magic tokens don’t match, no authorization protocol specified, can’t open display :0 inside restored tmux while i can in normal terminal). downgrade to 19.0

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.