KDE Dolphin Trash Limit Broken Suddenly

So today I was fiddling around with dolphin’s configure trash limit options , specifically the trash limit , I set it to around 128 gigs , because I keep downloading and deleting games , sometimes I have to recover data as well .

Now , after setting the trash limit to the default 10% ie 24.7 gigs , now if I click on move to trash for 40 gigs of files , they somehow get in the trash rather than the files too large popup appearing.

Today I was deleting the home/yeagerist/local/share/Steam folder before anything stated above happened , the folder was worth 36 gigs and when I clicked on move to trash , it didn’t go anywhere .

Not in the trash , nowhere . Suddenly I saw the free space on the lower right bar in dolphin showing 36 gigs more free space , the popup for files too large didnt appear then as well.

I dont know what broke this , any fixes ?

Thanks !

EDIT: Tried nemo and everything works perfectly.Still , would be nice to know what chugged things up and any possible fixes.

Have you updated and restarted your device since making this change? I ask because you said Nemo shows the right amount. Maybe even just closing all Dolphin windows might be enough.

Did everything, you know what , I noticed a new thing, on a live usb I get the popup too large to trash but on a installation from the beginning the limit is broken, so lemme try installing Endeavour OS with a separate root and home partition.

Guess what? Dolphin is broken , tried 2 distros and shit is severely broken . Trash limit don’t work.

Did you keep your home directory intact? If so, it may be a faulty Dolphin configuration. You may need to delete your Dolphin config files. Back them up before testing this.

Just tried reinstalling endeavour with separate home and root partitions, this don’t work.

Didn’t really answer my question. Are you using the default Dolphin config files or your own from a previous installation?

If you are not using old config files, then there may be a bug after all.

If it is a bug, try this:

Open Dolphin > Settings > Configure Dolphin > Context Menu > check "Delete"

This should give you the option to delete from disk directly. It will however, always ask for confirmation in case you made a mistake and meant to click “Move to Wastebin”.


image

Reinstalled , fresh config or shall I say new config , this happens with the 23.08.03 and tried 23.08.02 as well , now I will try lts kde on Ubuntu and see if this really a long pre-existing bug or introduced in newer versions.

Pause! View my edited reply, please. You are way too ready to reinstall all the time. That’s not how problems get fixed.

Context menu one ? Yes , this seems a good option but my biggest concern was when it deleted my steam folder without moving it to trash . Idk , I tried three more times with files worth GIGS and it did the same , I am not sure if it will happen again . Well just filed a bug report on KDE 's website.

You know trash bin is really handy for me , either switch de or switch to Nemo.

Well, Nemo has most of Dolphin’s features, so you won’t be missing much.

The DE has nothing to do with it, by the way.

Yes sort of but fyi I do a lot of trial and errors in these sort of issues before coming to conclusions that most of the time , are right.

I get that, but it would be rare that an entire installation is the problem rather than a few config files.

Yes I know but I really wanted to try out cinnamon to see it’s features and if it competes to kde in aesthetics.

Well just so you know I have all of my data on different partitions that I don’t touch during installs and really just modify the os partition. Plus I need only a handful of programs , so reinstalling is really like drinking water to me , very easy but time consuming.

That is quite true .

This is exactly what I’ve been asking you. :weary:

If you have the same Dolphin settings (config files) even after installing your OS, it is likely, very likely, to have the same issue.

The files in your Home/.config and Home/.local.

They can cause a minor issue to not get fixed if you keep them, even after a reinstall.

Sorry if I was inconvenient to you or a communication issue from my side but the home partition during my installs is included in the root partition, just tried separate today for a trial and error test but by data I mean games , photos and videos not config files . During a fresh install they all get replaced with their newly installed replacements.

I see. It’s not an inconvenience, or I wouldn’t even try to help. Just a communication misunderstanding. It’s all good.
:heart_hands:

1 Like

Have you ever faced such issues ?