Kde desktop and panels disappear randomly

The latest UEFI Bios is version F63d dated 2022/07/20

I searched a little and I don’t feel comfortable with that command but I’ll run it

It’s fine …it just will show if you are installed in UEFI or not.

EFI variables are not supported on this system.
That’s what it says

That’s what i thought as it looks like you have the system installed in Bios mode as your UEFI settings are set to UEFI-Legacy

  Type: Desktop Mobo: Gigabyte model: B450 AORUS M v: x.x
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: F50
    date: 11/27/2019

Edit: Also as i have said your UEFI Firmware(Bios) Is outdated.

Yeah, I never bothered updating the bios since I’m not able to purchase the 5000 series and therefore thought of updating the bios as too risky
Edit: Maybe I’ll try switching to xorg for now

Well that’s obviously your choice to update it or not. But i think it’s important to have the latest UEFI Firmware with Ryzen. It’s very easy to do. When you install normally you want secure boot disabled, CSM disabled, Fast boot turned off and set to UEFI only. Then your will boot in UEFI mode and install in UEFI. Having it installed in Bios mode you miss out on the features that UEFI provides. This all some what another issue from the problem you are having on Wayland. If you ever reinstall i would suggest you install it In UEFI mode and update the UEFI firmware (Bios) on the motherboard.

1 Like

So the problem could be because of not having the system on UEFI?
Also, I just tried x11… And the screen tearing is too noticeable I’ll just have to stick to wayland

Now that I think about it, maybe the cause could be my hard drive… I noticed it making noise for a while now, but no the clicking type, the noise it makes is constant. And now, some games that I have installed on it are going slow, tauon stopped and endeavour is having some weird lag now… I think my hard drive is going to die​:rofl:
Edit: For now I’m going to turn the pc down. Just to be safe

I’m not saying the screen tearing would be caused by it being installed in Bios mode. I’m just saying you have a modern UEFI motherboard and should be using it that way. The UEFI firmware is very important to how Ryzen CPU works as it contains new AGESA which controls all the power requirements for it. Obviously you can install it in Legacy mode but not sure why one would want to.

If you think your hard drive is dying i would suggest you use an m.2 drive or at least an SSD drive. Then if you reinstall you could set it up on UEFI only, possibly update the UEFI firmware and reinstall.

1 Like

Oh sorry, I confused you. I was trying to say that I can’t use x11 because of the screen tearing. And also I tried to ask you if maybe having endeavour installed with uefi could fix the problem I have with the desktop and panels disappearing.
Sorry, I tried to answer too many things at once.

You do, of course, have backups of your data on another drive/online?

Yeah, thankfully I was already suspicious of the hard drive yesterday and updated my backup on an external drive. I also have a backup on the cloud.

1 Like

What does

sudo smartctl -a /dev/your-drive


I don’t know how to read the information provided by smartctl.
Edit: I don’t actually know if it’s a problem caused by kde 5.26 or my hard drive. I’m honestly confused.

I don’t think it’s caused by Kde.

Oh no
Do you know how to interpret the information on smartctl?

Did you even run a test?

Edit: Need the drive name

sudo smartctl -t short /dev/*device*

Then look at the results

sudo smartctl -a /dev/*device*

Edit2: If you want to run a long test on the drive

sudo smartctl -t long /dev/*device*

I runned short tests for both sda and sdb and both say PASSED.
Plasma is still acting weird.

I have no idea what the image is supposed to show.

Edit: This error maybe tells more. Have you changed fonts? Maybe try that?

[2022-10-15T09:41:26-0300] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration