KDE - and plasma where to find the network with all the options

hi there - good day.

just installed on a Notebook Endeavour with KDE - and plasma. so - at the moment i wonder where to see the network-things - in other words where is the option to

a. find and
b. choose a WLAN network!?

in the right corner at the bottom i do not find anything.,

any idea

Press Alt+    Space     to open Krunner and type “settings” and select “System Settings”.

Then, on the left side of the System Settings application you have “Network” and “Connections”, “Settings” and “Firewall”.

hello dear Kresimir

many many thanks

great - and there - i see in “connections” - the

wire-connection. So i guess that i can add also Wifi

is there a option where i can see all the WLAN-networks…!?`

wlan0     Scan completed :
          Cell 01 - Address: 38:10:D5:E8:A8:C9
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=44/70  Signal level=-66 dBm  
                    Encryption key:on
                    ESSID:"FRITZ!Box 7412"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000001b6ca3f0413
                    Extra: Last beacon: 84ms ago
                    IE: Unknown: 000E465249545A21426F782037343132
                    IE: Unknown: 010882848B968C129824
                    IE: Unknown: 030106
                    IE: Unknown: 0706444520010D14
                    IE: Unknown: 2A0100
                    IE: Unknown: 3204B048606C
                    IE: Unknown: 2D1AEE111BFFFF000000000000000000000100000000000000000000
                    IE: Unknown: 3D16060D0600000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F080100000000000040
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0C00040E010102010000000000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD6F0050F204104A0001101044000102103B00010310470010BA62DEAEFE1524B7ECF93810D5E8A8C91021000341564D1023000446426F78102400043030303010420004303030301054000800060050F20400011011000446426F78100800022388103C0001011049000600372A000120
          Cell 02 - Address: 5C:49:79:B9:BC:24
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=35/70  Signal level=-75 dBm  
                    Encryption key:on
                    ESSID:"FRITZ!Box 7412"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000002ef451fd09
                    Extra: Last beacon: 84ms ago
                    IE: Unknown: 000E465249545A21426F782037343132
                    IE: Unknown: 010882848B968C129824
                    IE: Unknown: 030106
                    IE: Unknown: 0706444520010D14
                    IE: Unknown: 2A0100
                    IE: Unknown: 3204B048606C
                    IE: Unknown: 0B0500002A0000
                    IE: Unknown: 460573D000000C
                    IE: Unknown: 2D1AEF111BFFFF0000000000000000000001000000000406E6A70C00
                    IE: Unknown: 3D1606080000000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0805000F0000000040
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0C00040E010102010000000000
                    IE: Unknown: DD168CFDF00400004900000302097201000000003D000000
                    IE: Unknown: DD6F0050F204104A0001101044000102103B0001031047001002F9D86D47AE9C23EE9C5C4979B9BC241021000341564D1023000446426F78102400043030303010420004303030301054000800060050F20400011011000446426F78100800022388103C0001031049000600372A000120
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD088CFDF00101020100

[martin@martineos ~]$

wll i remember that in earlier times i had used kde nm - on opensuse
and other systems - it was easy to find all the networks… - and then i could choose one …and add all the credentials

but i am willing to dive into the new KDE plasma nm. - …

Check to see if you have the network-manager-applet package installed, if it is right click on the taskbar. From here move the mouse to the bottom right where the system tray is and select configure. Go to Entries and find the entry Networks and make sure this is checked to Show When Relevant or Always Show.
This should add it to your taskbar

Open konsole and see if network-manager is running:

systemctl status systemd-networkd

This will tell you if networkManager is up and on what device. i.e. eth0/wlan0…

If it says active and wlan0 has a ip your wireless lan is up. See if Kde networkmanager is installed:

sudo pacman -Ss plasma-nm

This should already be installed as it is a prerequisite of plasma. Then just follow smokey’s direcions.

good evening - many many thanks for the quick reply - so great. i am so happy to be part of this awesome community,


[martin@machine ~]$ systemctl status systemd-network
Unit systemd-network.service could not be found.
[martin@machine ~]$ systemctl status systemd-networkd
â—‹ systemd-networkd.service - Network Configuration
     Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
TriggeredBy: â—‹ systemd-networkd.socket
       Docs: man:systemd-networkd.service(8)
[martin@machine ~]$

well - probably i have something left to do here…

OK, in Konsole do:

systemctl enable systemd-networkd

Then immediately after:

systemctl start systemd-networkd

This should bring up your network and then the icon should show up. If not follow smokey’s directions.

many thanks -ä

i did this as adviced

artin@machine ~]$ systemctl status systemd-network
Unit systemd-network.service could not be found.
[martin@machine ~]$ systemctl status systemd-networkd
â—‹ systemd-networkd.service - Network Configuration
     Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
TriggeredBy: â—‹ systemd-networkd.socket
       Docs: man:systemd-networkd.service(8)
[martin@machine ~]$ systemctl enable systemd-networkd
Created symlink /etc/systemd/system/dbus-org.freedesktop.network1.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-networkd.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/sockets.target.wants/systemd-networkd.socket → /usr/lib/systemd/system/systemd-networkd.socket.
Created symlink /etc/systemd/system/sysinit.target.wants/systemd-network-generator.service → /usr/lib/systemd/system/systemd-network-generator.service.
Created symlink /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service → /usr/lib/systemd/system/systemd-networkd-wait-online.service.
[martin@machine ~]$ systemctl start systemd-networkd
[martin@machine ~]$

. this is what i have after following smokeys directions…

image##

i think that i have to run several commands to check what is going on here.
perhaps i have to check if all is set correct now.

OK, on the icon that looks like a PC with a cable running along the eft side, right click and there should be a submenu for wireless connections and then you should see your wlan ip name. select it and put in your credentials.

5 Likes

hello - i am happy - now i am connected via wlan
many thanks for the help - this is so awesome.

i love Endeavour - its so great - and the community is even greater - many thanks for all.

image

4 Likes

Glad you got it working

1 Like

Please mark my post as the solution so others can benefit from your experience. Thanks.

2 Likes