KDE advanced mouse options

If I’m reading this correctly, according to the KDE documentation at https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/mouse/index.html, the settings page for the mouse should have 3 sections (general, advanced and Keyboard navigation). My installation of EnOS with KDE (Plasma 5.20), however, only shows the general section.
Is there another app in which these settings can be modified? Or is there a .conf file somewhere where the options can be set manually?
thanks for your help!

1 Like

First, install the evdev input driver xf86-input-evdev by running:

sudo pacman -S xf86-input-evdev

Then create this file (owned by root): /etc/X11/xorg.conf.d/99-mouse.conf with the following content:

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

You can use Kate for that, as it makes it easy for you to save files as root.

Reboot.

Before, your Mouse settings dialogue looked like this:

After, it will look like this:

Welcome to the forum, btw.

7 Likes

Welcome to the community :beers:

1 Like

Thanks for your quick reply, however the problem remains.
After a reboot, the “Advanced” panel still does not show. Looks like libinput is still being used instead of evdev.

[eric@Aisen ~]$ pacman -Q xf86-input-evdev
xf86-input-evdev 2.10.6-2
[eric@Aisen ~]$ ls -lsa /etc/X11/xorg.conf.d/
total 16
4 drwxr-xr-x 2 root root 4096 Oct 30 10:18 .
4 drwxr-xr-x 4 root root 4096 Oct 12 11:50 ..
4 -rw-r--r-- 1 root root  266 Oct 12 11:50 00-keyboard.conf
4 -rw-r--r-- 1 root root  106 Oct 30 10:14 99-mouse.conf
[eric@Aisen ~]$ sudo pacman -R libinput
[sudo] password for eric: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libinput breaks dependency 'libinput' required by qt5-base
:: removing libinput breaks dependency 'libinput>=1.2.0' required by xf86-input-libinput

I suspect part of the problem is that the mouse I use reports 3 devices:

[eric@Aisen ~]$ cat /proc/bus/input/devices|grep MOUSE
N: Name="USB OPTICAL MOUSE "
N: Name="USB OPTICAL MOUSE  Keyboard"
N: Name="USB OPTICAL MOUSE  Consumer Control"

I might have to use the kd* conf files in ~/.config but I would prefer being able to use the evdev configuration page

I tried it on my KDE install and it works.

1 Like

That command doesn’t output anything for my mouse.
Edit: I change MOUSE to mouse

[ricklinux@eos-kde ~]$ cat /proc/bus/input/devices|grep mouse
H: Handlers=event5 mouse0 
H: Handlers=event7 mouse1 
[ricklinux@eos-kde ~]$ 
1 Like

I’m not sure what advantage these settings are? I have a cooler master combo mechanical keyboard gaming mouse RGB (Master Set MS121)

~🐸 grep -i mouse /proc/bus/input/devices 
N: Name="KYE SYSTEMS CORP. Wired Mouse"
H: Handlers=event18 mouse0 
[ricklinux@eos-kde ~]$ grep -i mouse /proc/bus/input/devices  
N: Name="Nuvoton MC120 RGB Gaming KB Mouse"
H: Handlers=event5 mouse0
N: Name="Cooler Master Technology Inc. MasterKeys Lite L Combo Mouse"
N: Name="Cooler Master Technology Inc. MasterKeys Lite L Combo Mouse"
H: Handlers=event7 mouse1
N: Name="Cooler Master Technology Inc. MasterKeys Lite L Combo Mouse System Contr
ol"
N: Name="Cooler Master Technology Inc. MasterKeys Lite L Combo Mouse Consumer Con
trol"
[ricklinux@eos-kde ~]$

@eric did you reboot?

yes, I did, and the settings page still does not show the advanced tab.

cat /var/log/Xorg.0.log
...
[     9.181] (II) config/udev: Adding input device USB OPTICAL MOUSE  Consumer Control (/dev/input/event24)
[     9.181] (**) USB OPTICAL MOUSE  Consumer Control: Applying InputClass "evdev keyboard catchall"
[     9.181] (**) USB OPTICAL MOUSE  Consumer Control: Applying InputClass "libinput keyboard catchall"
[     9.181] (II) Using input driver 'libinput' for 'USB OPTICAL MOUSE  Consumer Control'
[     9.181] (**) USB OPTICAL MOUSE  Consumer Control: always reports core events
[     9.181] (**) Option "Device" "/dev/input/event24"
[     9.181] (**) Option "_source" "server/udev"
...
[     9.208] (II) config/udev: Adding input device USB OPTICAL MOUSE  (/dev/input/event22)
[     9.208] (**) USB OPTICAL MOUSE : Applying InputClass "evdev pointer catchall"
[     9.208] (**) USB OPTICAL MOUSE : Applying InputClass "libinput pointer catchall"
[     9.208] (**) USB OPTICAL MOUSE : Applying InputClass "evdev pointer catchall"
[     9.208] (II) Using input driver 'evdev' for 'USB OPTICAL MOUSE '
[     9.208] (**) USB OPTICAL MOUSE : always reports core events
[     9.208] (**) evdev: USB OPTICAL MOUSE : Device: "/dev/input/event22"
...

looks like evdev is used for the main mouse device, but libinput is used for the other subdevices

My xorg log is huge!

http://ix.io/2CvF

as an alternative to using the UI to change the advanced settings, I might just use the config files. It looks like the mouse settings are saved in ~/.config/kcminputrc. If you change the “mouse wheel scrolls by” setting using the UI, which line is added/modified in your kcminputrc file?
thx!