Kalu - not waiting for internet connection

Hi,
I’m not sure wheter everyone is experiencing it, Kalu in my laptop is throwing errors at me just as the system starts, and is not waiting for WiFi connection to establish.

I think that calu shoud have some hook in NetworkManager to wait for connection establishing, or at least like 30 seconds sleep after system boot just to make sure that it’s not producing misleading errors.

NetworkManager should start your wifi at boot normally. kalu does not have a systemd service file to start at boot. such as pamac or octopi does have a service at boot. For example, if you do ctrl-alt-f2 as login manager and go to tty , you should have internet but kalu is not loaded in as example. kalu comes in at start up of your desktop

Perhaps my NM config is bit messed, first of all when I boot, I’m waiting for 90 sec timeout with:
A start job is running for /sys/subsystem/net/devices/enp0s31f6
I did pretty deep search on that (mostly arch wiki) and still no solution on my mind. I tried sysctl disabling, looking in init.d scripts, even removed some NM dependency - “icu” it was, afair.

I can see for example that WPA-Supplicant gets loaded at boot time, but I think that there’s no attempt to establish wifi connection at boot process, but I may be wrong.

It’s a little annoying, but yes…I’m having a similar issue. After I log in on my laptop, as soon as my desktop loads, Kalu pops up an error that it’s unable to connect. In two seconds, I’m connected to Ethernet according to the next notification. So, I can confirm the problem, but I have no idea how to resolve it unless there’s a way to tell Kalu to wait 10 seconds after login? I’ve DuckDuckGo’d (DDG’d?), and there are ways shown, but not entirely sure if they’re preferred.

It might work by putting kalu as a systemd service to depend on e.g. network-online.target.
I already tried it, but it didn’t work, just got a black screen. Seems like kalu does not work well with systemd.
This was what I tried:

[Unit]
Description=Start kalu when network is available
After=network-online.target

[Service]
Type=idle
ExecStart=/usr/bin/kalu

[Install]
WantedBy=network-online.target

in file /usr/lib/systemd/system/kalu.service, enabled it and rebooted.

So something was missing, don’t know what.

If someone gets that sorted, please report here! :slight_smile:

I have Wifi on two of my computers with Endeavour and when both boot up they are are automatically connected instantly and kalu runs right after and tells me there are updates or not and it is so fast. I have no issues with it. Wifi doesn’t wait to connect it is connected as soon as i see the desktop it’s there and the kalu icon starts flashing checking for updates. These are desktops not laptops.

i think give the some journalctl info , as on wiki https://endeavouros.com/docs/forum/how-to-include-systemlogs-in-your-post/

eventually : systemd-analyze critical-chain
NetworkManager probably looks for a wrong network ? but is mayby better to give the logs.

Hi @ricklinux
Did you disable kalu from autostarting at xfce session-and-startup?
OBS: otherwise having a systemd service would be useless.

No i have it running on my Xfce and Cinnamon desktops. The xfce version is ethernet and the other two cinammon are wifi but all of them have kalu in the startup applications. I have no issues with it on the wifi as my wifi is right there as soon as it starts up.

1 Like

@patryk and @Adam go to session and startup > automatic started > edit kalu entry by the command bellow.
You can test the better time for you, in the example is 10 seconds.

sh -c "sleep 10 && /usr/bin/kalu"

OBS: sorry my system is in portuguese.

2 Likes

So systemd service didn’t work at all or kalu was still set to autostart by xfce4?

@fernandomaroto; thanks! I’ll give that a try!!!

1 Like

@fernandomaroto, your solution worked perfectly for me! Thank you, again!!!

1 Like

Here is my settings on start up.

2 Likes

@fernandomaroto I’ll give it a try later today, thanks!

1 Like

But stil , it should not happend, NetworkManager is normally already loaded at boot.

1 Like

I removed kalu from autostart and had it only in systemd, with poor results.
But your solution to delay autostart is good.

1 Like

Ok, but isn’t this ethernet specific?
I know my father notebook usually only connects to wifi along with desktop loading, sometimes is possible to see the wifi icon “searching and connecting” animation
I guess wifi has some delay, not sure exactly how this works when needs to search for a saved password for example, while ethernet is “plug and play”

i can only read out of it it want to search a cable connection wifi generaly start with wlp…there is something messed up

It is just my thought, if you configure a connection and is for example all, it do running at system boot since :

A start job is running for /sys/subsystem/net/devices/enp0s31f6

it is searching for cable. NM does search network but only on wrong adress.

what is te systemctl status dhcpcd.service ?

but thats my thought, NM does load intoo boot even it is Wifi. wifi does work here only issue for me the attic and the wifi is to far :slight_smile: since kalu loads after startup has nothing todo on network startup the NM-applet is just a front.

1 Like