It actually happened!


I remember using slackware in the early days. While I have fond memories of those days, it is almost shocking how similar it is to the distro I used nearly 30 years ago.


I can’t recall if it was Debian or Slackware that I installed as my first Linux distro in 1994; they were definitely #1 and #2, but I’m not sure which held which title.

I still use Debian (Sid these days). The last time I installed Slackware was around 10 years ago and, yes, as @Dalto said, it was recognizably still the same old Slackware. Which isn’t a bad thing.


just tried it and yes feels like time traveling


The previous stable release was… 5 years ago? Good luck updating :grin:

Man I missed groundhog day!

less :fire: on OTBs video … :wink:


Life is to too short for package management that leaves you to sort out dependency management by yourself.

Yeah, nah.


When I used Slackware in the noughties, I kept up with slackware-current, and installed anything beyond the core system from source.
Worked flawlessly for years until the PC broke down from old age.
Most stable desktop OS I’ve ever come across.

If I had spare time enough to run a hands-on distro like that these days, I’d still be using it.


Welcome to the EndeavourOS forum. I hope you enjoy your time here.


1 Like

I just installed EOS and figured I ought to check in here. If only to keep up to date on any issues.

So far so good.
The laptop has a troublesome BCM43228 WLAN controller that no other distro has gotten quite right before.
Debian, Fedora spins, *buntu, OpenSUSE. Distros that normally work well, all had issues with this computer. The b43 driver was most stable but gave abysmal throughput. broadcom-wl gave good speeds, but dropped the connection several times per hour. Tried all suggested fixes/workarounds I found.
Sometimes the touch screen or special keys also needed extra fiddling about to get working.
Endeavour’s installer was the first live image where everything worked out of the box, and where I didn’t have to dig out a USB-Ethernet adapter to install the OS.
IIRC, it’s also the first installer that presented the option of configuring swap space for hibernation without doing manual partitioning. Small thing, but still nice.

Still no issues. No WiFi dropouts or slowdowns. Touch screen, special keys, hibernation, … Everything just works and feels snappy with the default install.
Normally that shouldn’t in itself impress. But with this particular laptop’s history, it really is a pleasant surprise.