Issues with creating a dual boot with artemis

I have been attempting to create a dual boot between windows 10 and endeavouros artemis. Both tutorials and general experimentations have been attempted. Neither have proven remotely successful.
I cannot find any tutorials relating to the artemis release and I presume something has changed significantly enough to alter the way that a dual boot must be set up.

Can I get any assistance with this issue?

Yes you can, start here:
https://wiki.archlinux.org/title/Dual_boot_with_Windows

What ISO are you trying to use?
Our latest release is Artemis and not Apollo.
You can grab it from here:

1 Like

Someone with a username like that one could just be trollin’.

Terribly sorry, I had a moment of dyslexia and got Greek names confused
I have now corrected it

This is just the username I’ve used for everything

1 Like

Nope, as far as I know nothing has changed significantly or at all regarding the boot process.

What tutorials have you followed
Do you have a legacy boot or UEFI?
You need to properly describe the issue and the steps you’ve taken so that people know what the issue is and attempt to reproduce it.

Can you start first by sending us hardware logs from the live ISO

inxi -Faz | eos-sendlog
1 Like

Also perhaps

sudo parted -l

so that we can see your disk setup.

And welcome to EnOS’ community @generic_idiot1!

:enos_flag: :handshake:t5:

Things can get really tricky when conditions like the one you name meet other ones, especially like e.g. ADHD.

Seriously not trying to be funny here…

Using inxi returned this


I hope it’s helpful

Is this output from the live ISO? What is the actual issue? Nothing in your post explains what the actual problem is that you are having.

There are various issues.
Having tried every combination of anything I could find on the topic nothing worked in the slightest.
There was always one os that refused to boot, or on one occasion it corrupted both and I had to wipe the drive.

I have asked here in a hope to avoid doing so again

Pleas post the terminal output as text and format it using code tags:

System:
  Kernel: 5.18.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/arch/boot/x86_64/vmlinuz-linux archisobasedir=arch
    archisolabel=EOS_202206 cow_spacesize=10G nvidia nvidia-drm.modeset=1
    nouveau.modeset=0 module_blacklist=nouveau i915.modeset=1
    radeon.modeset=1 nvme_load=yes
    initrd=/arch/boot/intel-ucode.img,/arch/boot/amd-ucode.img,/arch/boot/x86_64/initramfs-linux.img
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 1 dm: LightDM v: 1.30.0 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: H110M-K v: Rev X.0x
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 4210
    date: 06/25/2019
Battery:
  Device-1: hid-0003:256F:C62F.0001-battery
    model: 3Dconnexion SpaceMouse Wireless Receiver serial: N/A charge: N/A
    status: discharging
CPU:
  Info: model: Intel Core i7-7700 bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/4200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 57616
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Micro-Star MSI
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Turing process: TSMC 12nm
    built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: none off: HDMI-A-1 empty: DP-1,DVI-D-1
    bus-ID: 01:00.0 chip-ID: 10de:1f82 class-ID: 0300
  Display: server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1280x720 s-dpi: 46 s-size: 707x406mm (27.83x15.98")
    s-diag: 815mm (32.1")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: Sony TV
    serial: <filter> built: 2005 res: 1280x720 hz: 60 dpi: 44 gamma: 1.2
    size: 735x420mm (28.94x16.54") diag: 806mm (31.7") ratio: 16:9, 15:9
    modes: max: 1280x720 min: 640x480
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
    class-ID: 0403
  Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.5-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.59 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000AAVS-00ZTB0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1B01
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD5000AAVS-00ZTB0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1B01
    scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Hitachi model: HTS547575A9E384
    size: 698.64 GiB block-size: physical: 4096 B logical: 512 B
    speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: A50A
    scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Generic model: Flash Disk
    size: 1.9 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 8.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: N/A size: 10 GiB used: 1.8 MiB (0.0%) fs: overlay
    source: ERR-102
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 211 Uptime: 5m wakeups: 1 Memory: 7.7 GiB
  used: 945.4 MiB (12.0%) Init: systemd v: 251 default: multi-user
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 898 lib: 212
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.18
1 Like

From the live session, could you post the output of:

test -d /sys/firmware/efi && echo UEFI || echo BIOS

sudo parted -l

?

test returned BIOS
parted gave

Model: ATA WDC WD5000AAVS-0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB  16.8MB               Microsoft reserved partition  msftres
 3      123MB   500GB  499GB   ntfs         Basic data partition          msftdata
 4      500GB   500GB  534MB   ntfs                                       hidden, diag


Model: ATA WDC WD5000AAVS-0 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      1049kB  500GB  500GB               Basic data partition  msftdata


Model: ATA Hitachi HTS54757 (scsi)
Disk /dev/sdc: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start  End  Size  Type  File system  Flags


Model: Generic Flash Disk (scsi)
Disk /dev/sdd: 2045MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      1833MB  1940MB  107MB  primary  fat16        esp

Since your Windows (on /dev/sda) is installed in UEFI mode, you would need to install EnOS in the same mode as well. For that you should be booting up your live USB in UEFI.

Go into the firmware settings (BIOS/UEFI settings) and disable Legacy and/or CSM boot mode.
Boot up your live usb and try installing again.

In case you have any doubts/questions, please feel free to post them here.

Which install method do you recommend? As I have seen many conflicting info on placement of bootable/tagging various drives

You seem to have Windows installed in UEFI mode so the most straightforward way to a working dualboot would be to install EnOS in UEFI mode as well.

Are you going to install on /dev/sdb ?

A) I do not care where it is installed as long as it functions

B) I can no longer open the live version. After asking me to select an option the screen just goes black and doesn’t appear to being starting