Issues on brightness commands and function keys on NVIDIA install

I dualbooted my laptop with Windows 10 and EndeavourOS, and initially, I was able to change the brightness with a custom command (I did Ctrl + F5, Ctrl + F6 before). However, i recently did nvidia-installer-dkms to update drivers, but now the shortcut doesn’t work anymore.

I can currently do sudo xbacklight -inc 10 or sudo light -A 10 on Konsole to change the brightness (doesn’t work without sudo), but it would be nice if I could wire it to a custom shortcut, which makes it not work. How can I use shortcuts to change brightness again?

This is the output of inxi -Fxxxc if needed:

  Host: ideapad Kernel: 5.19.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
    dm: 1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: EndeavourOS
    base: Arch Linux
  Type: Laptop System: LENOVO product: 82H8 v: IdeaPad 3 15ITL6
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 15ITL6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN
    serial: <superuser required> UEFI: LENOVO v: GGCN20WW date: 01/13/2021
  ID-1: BAT0 charge: 26.4 Wh (82.2%) condition: 32.1/38.0 Wh (84.6%)
    volts: 8.6 min: 7.7 model: BYD L20B2PF0 type: Li-poly serial: 563
    status: charging cycles: 831
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    smt: enabled arch: Tiger Lake level: v4 rev: 1 cache: L1: 320 KiB L2: 5 MiB
    L3: 12 MiB
  Speed (MHz): avg: 2587 high: 2800 min/max: 400/4700 cores: 1: 2800
    2: 2800 3: 2800 4: 2800 5: 1100 6: 2800 7: 2800 8: 2800 bogomips: 44864
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: N/A
    arch: Turing bus-ID: 0000:01:00.0 chip-ID: 10de:1f97 class-ID: 0302
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-5:3 chip-ID: 04f2:b725 class-ID: fe01 serial: 0001
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x151e res: 1920x1080
    hz: 60 dpi: 143 size: 340x190mm (13.39x7.48") diag: 394mm (15.5")
    modes: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8
    class-ID: 0401
  Sound Server-1: ALSA v: k5.19.8-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlan0 state: up mac: 4c:79:6e:e9:2d:11
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 3-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
  Local Storage: total: 476.94 GiB used: 13.56 GiB (2.8%)
  ID-1: /dev/nvme0n1 vendor: Lenovo model: UMIS RPJTJ512MEE1OWX
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: SS1B60639Z1CD13T11RP rev: 2.1C0628 temp: 50.9 C scheme: GPT
  ID-1: / size: 143.13 GiB used: 13.53 GiB (9.4%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 256 MiB used: 33.4 MiB (13.0%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.

I’m also a newbie in linux forum debugging in general, so please let me know if you need any logs from me. Thanks!

Add yourself to the video group.

sudo gpasswd -a <your_user> video

That should remove the need for sudo and then add as shortcuts.

1 Like

See also:

thanks this worked!

As for this, I did want to try going this route before, hoping that I learn to fix more NVIDIA issues that probably will come up.

I didn’t have a file named 20-nvidia.conf in my X11/xorg.conf.d folder, in both the one in /etc and /usr/share. My /etc/X11/xorg.conf.d folder contains only 00-keyboard.conf, but the /usr/share one has 10-nvidia-drm-outputclass.conf 10-quirks.conf 30-touchpad.conf 40-libinput.conf.
Do you think it’s just fine to create /etc/X11/xorg.conf.d/20-nvidia.conf file like this from scratch? Even then though, I wouldn’t know what to write there :thinking:

EDIT: also I tried adding the line "RegistryDwords" "EnableBrightnessControl=1" to 00-keyboard.conf and to 10-nvidia-drm-outputclass.conf and in both cases my DE won’t boot up at all (I had to Ctrl + Alt + F7 to go to TTY7), so I’m not sure if any solution along these lines would work. I wouldn’t expect anyone to know the solution to this, but if someone does figure it out, that would be nice :smiley:

Yes, although there’s no need as you can just add the kernel parameter instead.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.