Issues installing ttf-unifont

I am trying to install polybar and one of the requirements is the addition of a package called ttf-unifont When trying to install this package I cannot import the pgp key. I have already tried editing /etc/pacman.d/gnupg/gpg.conf and changing the keyserver.

This is the output:

[endeavouros@endeavouros-i3 ~]$ yay ttf-unifont
2 aur/ttf-unifont-csur 12.1.04-1 (+3 0.00) 
    TrueType part of the GNU Unifont containing Michael Everson's ConScript Unicode Registry (CSUR) Private Use Area (PUA) glyphs
1 aur/ttf-unifont 13.0.03-1 (+106 1.08) 
    TrueType version of the GNU Unifont
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  ttf-unifont-13.0.03-1

  1 ttf-unifont                      (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: PKGBUILD up to date, Skipping (1/1): ttf-unifont
  1 ttf-unifont                      (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: (1/1) Parsing SRCINFO: ttf-unifont

:: PGP keys need importing:
 -> 95D2E9AB8740D8046387FD151A09227B1F435A33, required by: ttf-unifont
==> Import? [Y/n] y
:: Importing keys with gpg...
gpg: keyserver receive failed: General error
problem importing keys

Looks like a keyserver issue.

If you trust this package (this is a general warning, not directed specifically to this package), you can use pacman-key with options --recv-keys, --lsign-key and --keyserver. Something like:

sudo pacman-key --keyserver <keyserver-name> --recv-keys <key>
sudo pacman-key --lsign-key <key>

<keyserver-name> could be e.g. hkp://

So strange neither of those options work? This is on two separate machine with i3 installed.

endeavouros@endeavouros-i3 ~]$ sudo pacman-key --lsign-key 95D2E9AB8740D8046387FD151A09227B1F435A33
[sudo] password for endeavouros: 
  -> Locally signing key 95D2E9AB8740D8046387FD151A09227B1F435A33...
==> ERROR: 95D2E9AB8740D8046387FD151A09227B1F435A33 could not be locally signed.
[endeavouros@endeavouros-i3 ~]$ sudo pacman-key --keyserver khp:// --recv-keys 95D2E9AB8740D8046387FD151A09227B1F435A33
gpg: keyserver receive failed: No keyserver available

Typo? :wink:

khp --> hkp


If you’re using hkps:// then this implies TLS for the pool is still broken. :disappointed:

Personally, I’ve just switched to keyserver hkps:// and it all works (using a single keyserver will solve the TLS certificate issue anyway).