Issues after removing laptop from docking station

I have a Microsoft USB mouse that I’ve been using for the past year or so. I have had it plugged in both to a Dell docking station (not meant for my ThinkPad, but I used it with it because I had it for work) and into the ThinkPad directly. I’m not going to have that docking station anymore, so I transferred anything plugged into it into my computer. My mouse won’t work unless the docking station is plugged in, regardless of whether the USB dongle is plugged into the docking station or into the USB port directly. I have confirmed this several times, and I have no idea how to fix that. It just doesn’t make sense to me as to why the dock being connected affects the mouse on the other USB port. Is there a way to purge the docking station from my system somehow? I’ve found that the ethernet port isn’t working either with my network cable plugged in directly, but I’m not sure if that is related or not.

You had also to setup the dock station in endeavouros ? just curius… mayby it has something to do on power rulez etc… with out the dock but with only powersource it also does not as it do?

I did not set up the dock at all, it was a USB-C that I just plugged in to the power port, and it worked. I’ve tried it plugged in to its proper power adapter, but that doesn’t seem to fix it. Good thought though, thank you.

I think I have it fixed! I’m not clear on why this happened, but I noticed that the mouse adapter stayed listed in the mouse inputs even between reboots. What I ended up doing was plugging in a different mouse, which cleared out the mouse that I wanted to use from being listed and then plugged the mouse I wanted to use back in. I’m not sure why, but whatever it was hanging onto regarding the mouse needed to be cleared before it would look for it correctly again.

Months later, I’ve realized that the issue was being on battery power. TLP was having an issue with the USB ports on battery even if the auto-suspend was off.

What I found was that it was an ahci driver and tlp issue for me, after changing the USB Auto-suspend didn’t work.

The workaround was to remove values from the AHCI_RUNTIME configurations on the tlp config


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.