Issue with updating Perl and ClamTK not working

Hello , Been a couple weeks were
perl not updating . I get this message ( could not satisfy dependencies:
installing perl (5.32.0-1) breaks dependency ‘perl<5.31’ required by perl-gtk2-unique ).
How do i fix this ?
Also today i wanted to run ClamTk , and its not working either .
I get this message in terminal -
( Can’t locate Glib.pm in @INC (you may need to install the Glib module) (@INC contains: /usr/lib/perl5/5.30/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.30/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.30/core_perl /usr/share/perl5/core_perl) at /usr/share/perl5/vendor_perl/ClamTk/Analysis.pm line 15.
BEGIN failed–compilation aborted at /usr/share/perl5/vendor_perl/ClamTk/Analysis.pm line 15.
Compilation failed in require at /usr/bin/clamtk line 22.
BEGIN failed–compilation aborted at /usr/bin/clamtk line 22.

Can it be that Perl issue causeing Clamtk issue ?
Needing help to fix problems , THANK YOU

Here is a way to fix your problems.

  • For perl-gtk2-unique: AUR package which needs to be rebuild.

So, first step is to upgrade your system by doing:

sudo pacman -Rdd perl-gtk2-unique

After upgrade your system.

Build again perl-gtk2-unique with yay for example:

yay -S perl-gtk2-unique

  • For clam-tk?

Until you upgrade perl - blocked by perl-gtk2-unique - it won’t work.

3 Likes

Worked ! Thank you very much ! Awesome !

You’re welcome.

Please check “solved” case on the post which give you the answer.

1 Like

Allow me @FredBezies.

1 Like

but that perl-gtk2-unique is used by

just curius :slight_smile:

All AUR packages. Weird there are not for some of them, like shutter or pacmanager on community.