Issue on installing .tar.gz

Hi, I don’t have much experience and I haven’t found a solution to my problem.

I’m trying to install a .tar.gz (https://github.com/LongoMatch/longomatch-core/releases) but when I go to ./configure I don’t have the ‘newtonsoft-json’ package, and I can’t get it - anyone have a solution? Thanks!

I guess the file you downloaded is a dotnet project and as such you need dotnet installed - newtonsoft-json is a well know library used for dot net applications.

You will most likely find more information in the projects github page - also with relation to installation - unless it assumes you are a developer and know your way around dotnet.

************
Dependencies
************

 * Mono >= 2.0
 * GTK# >= 2.12
 * GStreamer >= 0.10.24
 * Json.NET >= 5.0

Thank you for this answer, I’m still working on it, maybe you could help me again

I installed dotnet with

sudo pacmac -S dotnet-sdk

To install the package I want I found :

sudo dotnet add package Newtonsoft.Json

As I have several project files (’.csproj’) in the folder, how can I know on which one I have to add the package?

This is an archive file containing the source code for that release - it is not installable.

The compilation instructions are on the project page:

3 Likes

You are right, thank you! I’m going to bother you again, since it’s in python2, do you know how I can switch from python3 to python2? I tried to create an alias in the bash_profile but when I run the line :

$ ./cerbero-uninstalled -c cerbero-extras/longomatch.cbc bootstrap

It keeps running with python 3

Do you have the python2 package installed?

Yes it is installed.

Why is that necessary?

When running

$ ./cerbero-uninstalled -c cerbero-extras/longomatch.cbc bootstrap

It runs a program written in python2

1 Like

Which one?

In the import folders of github, I have several .py files including main.py which is running. I saw it when I had an error running the code in the terminal where the syntax was wrong. I deduced by opening the file that it is written in python2.

I was asking because it should be possible to change the shebang or executing line to use python2 rather than python, but if you can’t tell me the specific file then I can’t look at it.

Otherwise, it is possible to override the python executable by setting a local $PATH variable that contains a symlink to python2, then everything will be run with python2 by default. For example:

ln -s /usr/bin/python2 python
export PATH=.:$PATH
python -V

It works fine, however it tells me that the distribution is not supported, end for me. Thanks for everything, I learned a few things!

1 Like

That is probably going to break stuff.

Surely, it’s better to change all references of python to python2 in the script in question? It’s probably just the #! line.

Yes, which is why I asked for the specific file in question. :wink:

However, the symlink will only break things for a shell where the $PATH is overridden, and software compiled/configured in that way likely won’t work without that override, but other than that it’s pretty self-contained.

Most software outside of Arch expects python to be python2, and python3 to be python3, so it’s unlikely to affect software that’s not already using Python 3 as the default; this particular software hasn’t been updated since 2017 so I was fairly confident it wouldn’t expect python3 to be the default interpreter.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.