Iso9660-levyjen lukeminen

Hei,
kompastuin ilmeisesti klassikkoon eli iso9660-levyihin.

Juuri päivitetty EOS-koneeni ei kuitenkaan automaattisesti pysty ottamaan levyä kyytiin. Mitä tehdä? Manuaalisestikaan se ei ilmeisesti ilman kikkaa onnistu…

Veli-Pekka

1 Like

Tervetuloa @VPP

Arch wikissä on tietoa tästä:
https://wiki.archlinux.org/index.php/Optical_disc_drive
Saatat myös löytää tämän hyödyllisen:

Google Translate

Kiitos! Olen kyllä hengaillut täällä jo jonkin aikaa…

CD sisältää jonkinlaisia esityksiä eikä siis ole mikään audiolevy. Se pitäisi pystyä mounttaamaan, mutta EOS ei taida sitä suoraan tukea. “iso9660” on virheilmoituksen mukaan tuntematon tiedostojärjestelmän tyyppi.

Veli-Pekka

1 Like

Jos tämä on tämä viesti:

mount: /mnt/cdrom: wrong fs type, bad option, bad superblock on /dev/sr0, missing codepage or helper program, or other
error.

Try some of the options in the second link

Google Translate

Error mounting /dev/sr0 at /run/media… : unknown filesystem type ‘iso9660’.

Yritin avata levyä suoraan tiedostoselaimella. Manuaalisesti kokeiltuna viesti on kuten edellä sanoin. Toinen linkki käsittelee audiolevyjä ja levyjen kirjoittamista. se ei kai auta, jos tukea iso9660:lle ei ole.

Veli-Pekka

Mitä levyllä on?

Palaa myös terminaalista ``

inxi -Fxxxza --no-host

Luultavasti jokin multimediaesitys.

inxi:

$ inxi -Fxxxza --no-host
System:
  Kernel: 5.10.7-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/vmlinuz-linux 
  root=UUID=da7a9d4e-fd16-4ce2-97ed-fe231b9e9e05 rw quiet 
  acpi_enforce_resources=lax 
  resume=UUID=cbe4a8a8-1364-48d3-83fd-8e4579b79880 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.24 wm: gnome-shell 
  dm: GDM 3.38.2.1, LightDM 1.30.0 Distro: Antergos Linux base: Arch Linux 
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z77-D3H v: x.x serial: <filter> 
  UEFI: American Megatrends v: F23b date: 01/06/2014 
CPU:
  Info: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 28 
  L2 cache: 6 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 24833 
  Speed: 1815 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1815 2: 1601 
  3: 1601 4: 1602 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: Gigabyte driver: nvidia 
  v: 460.32.03 bus ID: 01:00.0 chip ID: 10de:1287 class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: gnome-shell driver: 
  loaded: nvidia display ID: :1 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
  s-diag: 583mm (23") 
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 96 
  size: 510x287mm (20.1x11.3") diag: 585mm (23") 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 class ID: 0403 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 
  class ID: 0403 
  Sound Server: ALSA v: k5.10.7-arch1-1 
Network:
  Device-1: Qualcomm Atheros AR9227 Wireless Network Adapter driver: ath9k 
  v: kernel port: e000 bus ID: 04:01.0 chip ID: 168c:002d class ID: 0280 
  IF: wlp4s1 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: Gigabyte 
  driver: alx v: kernel port: d000 bus ID: 05:00.0 chip ID: 1969:1091 
  class ID: 0200 
  IF: enp5s0 state: down mac: <filter> 
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus ID: 1-1.2:3 chip ID: 0a12:0001 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
Drives:
  Local Storage: total: 6.5 TiB used: 2.4 TiB (36.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD1002FAEX-00Y9A0 size: 931.51 GiB block size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1D05 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WD20EZRX-00D8PB0 size: 1.82 TiB block size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 0A80 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate model: BUP BK 
  size: 3.64 TiB block size: physical: 4096 B logical: 512 B 
  serial: <filter> rev: 0108 
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Kingston 
  model: HyperX Savage size: 117.25 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: PMAP 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-5: /dev/sde maj-min: 8:64 type: USB vendor: Kingston 
  model: DataTraveler G3 size: 14.64 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: PMAP 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition:
  ID-1: / raw size: 923.31 GiB size: 908.7 GiB (98.42%) 
  used: 135.82 GiB (14.9%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 
  ID-2: /boot raw size: 256 MiB size: 247.9 MiB (96.84%) 
  used: 60.9 MiB (24.6%) fs: ext2 dev: /dev/sda2 maj-min: 8:2 
  ID-3: /boot/efi raw size: 200 MiB size: 196.9 MiB (98.45%) 
  used: 12.2 MiB (6.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.76 GiB used: 466.7 MiB (5.9%) 
  priority: -2 dev: /dev/sda4 maj-min: 8:4 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 242 Uptime: 21d 22h 42m wakeups: 252 Memory: 7.73 GiB 
  used: 2.82 GiB (36.5%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 1465 lib: 391 Shell: Bash v: 5.1.4 
  running in: gnome-terminal inxi: 3.3.00
1 Like

Olet ollut jo pitkään :slight_smile:

Distro: Antergos Linux -perusta: Arch Linux

Ja niin on BIOS:

UEFI: American Megatrends v: F23b päivämäärä: 1.6.2014

Voit kokeilla toista ydintä. Esimerkiksi linux-lts

On aina hyvä tapa, että varmuuskopioitu ydin asennetaan joka tapauksessa.

Olen varma, että Arch linux tukee ISO9660: ta, mutta mielestäni se on otettava käyttöön / lisättävä.

Jep!

Vaatisi hieman perusteluja ja neuvoja!

Mä en tiedä paljonko tässä koneessa on enää Arch-linuxia. Varmaan vanha qt4 (uudelleen kääntymätön) ja jotain muuta. Eikö siis EOS tue? Voiko asentaa jostakin?

1 Like

Minun on läpäistävä tämä tässä vaiheessa. En halua tehdä virhettä Google-käännöksessä, joka vahingoittaa järjestelmääsi.
@manuel voi auttaa tässä.

1 Like

Auttaako man mount jos etsit sanaa iso9660?

Google translator is funny. If the above is translated into English, it would be something in the lines of: “I must go through this at this stage.” :wink:

Anyway, thanks for using Finnish! :+1:

1 Like

OK, @manuel osaa suomea hyvin. Tosin voinhan avata saman General Systemsinkin puolelle.

Se voisi olla hyvä idea, koska mulla ei enää ole cd-asemaa koneessa. Ei siis pitkään aikaan. :wink:

Ok, pitää varmaan monistautua. Itse mount-komennon kertaaminen ei auta, kun tukea iso9660:lle ei taida olla.

En mäkään tosiaan cd-levyjä juuri käytä, niitä vain sattuu vielä olemaan. Yksi kaveri Englannista haluaa oppia suomen kieltä ja multa löytyy helppo kurssi kahdelta cd-levyltä. Haluaisin katsoa ovatko levyt samat ja lähettää toisen kaverille.

Minkälaista mount-komentoa olet yrittänyt käyttää?
Periaatteessa iso9660 pitäisi olla tuettu.

Esim.

 sudo mkdir -p /CD
 sudo mount -t iso9660 /dev/... /CD  # komento lsblk -fm pitäisi näyttää tuo /dev tarkemmin

Tietysti on mahdollista, että cd-levy on rikki…

Yleensä annan tiedostopalvelimen mountata sen. Mutta sitten sitä ei voi lukea. Olen käyttänyt pelkkää mount ja sitten mount -t -komentoja.
Tässä lsblk-tulostus:

# lsblk -fm /dev/sr0
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT   SIZE OWNER GROUP MODE
sr0  iso966 Jolie Talk Now!
                        2003-06-27-13-42-22-00                                         660,6M root  optic brw-rw----

Onko sen tyyppi tosiaankin iso966 vai onko tuo vain typo?