Is There a Way to Make Panel Icons Larger?

I don’t want the panel size any larger but as you can see in the image below, the panel/tray icons are a lot smaller than the open programs icons on the left. There seems to be a lot padding on either side of the icons.

Enter edit mode and see which widget is the larger icons and make the second one the same widget or see if there are settings on that widget with smaller icons (they should aslo showin edit mode)

I’m not seeing that a Widget has an effect on the icons in Panel Configuration?

Move your cursour there in edit mode, I think it’s one of the widgets, my panel is not close to stock so I can’t check

What are the options if you click configure? I have this removed. If that has no setting I woudl check what the other widget is and perhaps replace this with that. (If you want to test safely without messing your current setting make a new user and experiment in that)

You want to configure the tray, so in edit mode right-click the little up-arrow of the tray and select configure system tray.


There you can select icon size and spacing though the options are limited.

I think they are trying to edit a different section (see screenshot) but I would assume it should have similar options

No options to resize icons in the Task Manager and already have “Scale with Panel Height” selected.

Have you tried removing that and replacing it with the other one that does scale?

I believe it’s the same across the screen to the System Tray?

I found there’s a huge difference between panel height @ 48 and anything below that as far as panel icon sizes when using scale with panel option.

Maybe there’s a config file somewhere that would allow increasing the icon size on smaller panel heights?

46 panel height…

48 panel height…

The only other setting is in system tray settings to set scale with panel height. Not sure if this helps you.

Yeah, that’s what I meant by the disparity in icon sizes between 48 height size panel and 46 and below height size panels. If I untick the scale option then there is only a “Small” icon option.

In Cinnamon and XFCE there is a preference to set icon sizes but I don’t see that in KDE.