Is there a no-confirm option to update the os?

From the welcome menu I do ‘Update System (eos-update -aur)’. I presume this is identical to the command shown. I keep missing a prompt because it waited for too long. Hence the question in the title. Alternatively, how would I override the timer associated with the prompt?

$ sudo eos-update -aur --noconfirm
[sudo] password for erwann: 
eos-update: invalid option -- 'a'
eos-update: invalid option -- 'u'
eos-update: invalid option -- 'r'
eos-update: unrecognized option '--noconfirm'
eos-update is a package updater for EndeavourOS and Arch.

eos-update is implemented as a wrapper around commands pacman and optionally yay/paru.
Essentially runs commands 'pacman -Syu' and optionally 'yay -Sua' or 'paru -Sua'.

eos-update includes (by default) special help in the following situations:
- A dangling pacman db lock file (/var/lib/pacman/db.lck).
- Disk space availability for updates (with a configurable minimum space).
- Keyring package updating before others.
- Running the 'sync' command after update.

Optional help:
- Can clear package databases in case of contant problems with them.
- Can reset keyrings in case of constant problems with them.
- Updates AUR packages (with option --helper, see Usage below)
- Ad hoc check for Nvidia GPU driver vs. kernel updates:
  - kernel-lts updates ==> nvidia-lts should be updated
  - Nvidia driver:  nvidia  nvidia-lts
  - Kernel:         linux   linux-lts
  (only on EndeavourOS).

Usage: eos-update [options]
Options:
  --help, -h         This help.
  --nvidia           Check also nvidia driver vs. kernel updates. Useful only with the Nvidia GPU.
  --nvidia-auto      If nvidia module is in use, automatically apply option --nvidia.
  --clear-databases  Clears package database files.
                     Use this only if package database issues constantly make system update fail.
  --keyrings-reset   Resets Arch and EndeavourOS keyrings.
                     Use this only if keyring issues constantly make system update fail.
  --no-keyring       Do not try to update keyrings first.
  --no-sync          Do not run 'sync' after update.
  --helper           AUR helper name. Supported: yay, paru, pacman.
                     Default: pacman
                     Other AUR helpers supporting option -Sua like yay should work as well.
  --paru             Same as --helper=paru.
  --yay              Same as --helper=yay.
  --aur              Uses the AUR helper configured in /etc/eos-script-lib-yad.conf.
  --pacman           Same as --helper=pacman. Default. (Note: pacman does not support AUR directly).
  --min-free-bytes   Minimum amount of free space (in bytes) that the root partition should have
                     before updating. Otherwise a warning message will be displayed.
                     Default: 1000000000

Tip: create an alias in file ~/.bashrc for eos-update to have the options you need, for example:

     # Enable Nvidia update check, disable sync execution, use paru for AUR updates.
     alias eos-update='eos-update --nvidia --no-sync --paru'

I think the command is just eos-update I may be wrong as I’ve never used it

If you want to update your system just use yay

The icky part is " I keep missing a prompt because it waited for too long".

You shouldn’t use --noconfim on Arch. It can cause breakage. It also won’t help if the prompt you are missing is the password prompt.

Instead, set the option to enable sudoloop. Like this:

yay --sudoloop --save
1 Like

I would just watch it then, updates don’t normally take too long unless you are building a large package off the AUR
EDIT - I would listen to @dalto he is way more knowledgable than me

I want prompts to get automated as “go with the default”. What you’ve shown me doesn’t achieve that, I just tried.

Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)

I am telling you that isn’t safe to do. You shouldn’t automate updates on Arch.

Also, how could you miss that prompt? It comes at the beginning of the process.

2 Likes

Never do this, you may end up installing something you don’t want or that conflicts with other stuff

My Internet is very slow and unreliable. So I made a systemd service-unit and a timer. The service-unit runs a script, which will update the database and only download new software. For this case I use “–noconfirm”. When the download (or my work) is done, I can install the new packages without waiting for my slow internet connection.
But I won’t install new software without looking at the screen.

@erw1, you should not attempt to automate updates on Arch Linux. That’s a sure way to end up with a broken system, sooner or later.

If you need automatic updates, it would be much better to use another distro, really. You can stay on the forum, I’m not telling you to go away, just that Arch/EndeavourOS is not a good distro for those who want automatic updates.

3 Likes